NAS SW Rear Defrost Issue - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old November 24th, 2014, 07:38 PM
sloanfiske's Avatar
sloanfiske
Status: Offline
Anthony Nelson
97 D90 SW
Member
 
Join Date: Mar 2008
Location: New York
Posts: 435
Registry
NAS SW Rear Defrost Issue

so, odd question...

when i open the doors and the dome light comes on, the defrost light on the dash lights up.

i can hear intermittent buzzing from the relay when it's on.

if i close the door and the light goes out...so does the light.

if i turn on the light manually with the door closed, the defrost light does not come on

when i hit the momentary switch, the defrost works as it should.

i've checked the connections at the light in the dash, on the momentary defrost switch, and on the door switches.

any thoughts? bad relay causing the issue?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old November 24th, 2014, 09:18 PM
leastonce's Avatar
leastonce
Status: Offline
Jason England
D-90 White 95 SW #65
Site Team
 
Join Date: Jul 2009
Location: NYC
Posts: 6,078
Registry
Quote:
Originally Posted by sloanfiske View Post
so, odd question... when i open the doors and the dome light comes on, the defrost light on the dash lights up. i can hear intermittent buzzing from the relay when it's on. if i close the door and the light goes out...so does the light. if i turn on the light manually with the door closed, the defrost light does not come on when i hit the momentary switch, the defrost works as it should. i've checked the connections at the light in the dash, on the momentary defrost switch, and on the door switches. any thoughts? bad relay causing the issue?
bad ground somewhere.
__________________
Quote:
Soapy water / KY jelly, etc. is is basically a must. Yes, good idea to remove trim panels - only takes 5 more minutes to do so.
Car Camping Collective founding member and Chief Executive Officer
Cat Camping Collective founding member and Chief Executive Officer
Reply With Quote
  #3  
Old November 24th, 2014, 09:24 PM
sloanfiske's Avatar
sloanfiske
Status: Offline
Anthony Nelson
97 D90 SW
Member
 
Join Date: Mar 2008
Location: New York
Posts: 435
Registry
NAS SW Rear Defrost Issue

Yep. Kinda figured. God only knows where.

Thanks
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old November 25th, 2014, 11:40 AM
kevincdoyle's Avatar
kevincdoyle
Status: Offline
Kevin C. Doyle
1995 NAS D90 Coniston Green SW
Member
 
Join Date: Nov 2003
Location: Tulsa, OK USA
Posts: 862
Registry
Quote:
Originally Posted by sloanfiske View Post
Yep. Kinda figured. God only knows where. Thanks
You might check the passenger rear under the trim piece that surrounds the rear most window first. I had a ground pull out there that was causing issues..
__________________
Attributed to Shayne...

"I actually like to paint some of my smaller parts......"
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
nas

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear Defrost Switch, Rear Wiper Switch, and Rear Wipe/Wash Switch bradfordish For Sale - Parts 5 January 26th, 2014 12:30 PM
Relocate Rear wiper / Defrost switch kinetic Defender Technical Discussions 4 February 8th, 2013 07:07 PM
defrost that middle part CDNRover Defender Technical Discussions 10 January 7th, 2012 02:51 PM
Broken Defrost Diverter Cable? Wolf Fabrication Defender Technical Discussions 4 June 26th, 2008 04:15 PM
trailer light and defrost lite won't go out!? chidiesel Defender Technical Discussions 0 February 18th, 2004 03:39 PM


All times are GMT -5. The time now is 06:21 AM.


Copyright