NAS 110 Won't start after snorkel - Page 2 - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Join the Defender Source Community Today

Thread Tools
Old March 9th, 2015, 11:33 AM
Ren Ching's Avatar
Ren Ching
Status: Offline
Skinny Pete
'84 90 "Yamelo"/'88 RRC "Chewbacca"
Join Date: Mar 2007
Location: Downtown
Posts: 4,556
Glad you caught it. Mine was loose on my Classic. A gnat could have landed on it and shut the car down. I just squeezed the contacts together to tighten them up and haven't had a problem since.

That is the plug for your ignition amplifier module.

Originally Posted by emah View Post
Found the was a plug that goes from the coil to right below the disturbutor see plug 1. It has 2 white wires and split loom tubing in pic. It's slightly loose and when the engines is on and you wiggle the wires the engine shuts off. I need to replace that wire connector. Anyone know what that is called?
Thanks everyone for your help in trouble shooting this. I found out after I checked for spark.


1960 SII 109"- "Red Square"
1984 90 Tdi- "Yamelo"
1988 RRC- "Chewbacca"
1987 RRC- "Chewy 2"
2008 RRS SC- "The Supersofa"

1959 SII 88"- "The Little Green Beastie" last seen in NY
1972 SIII 88"- "GreenHELL" now in NC
1988 90 "Eric the Half a Bee" half a truck, sold for parts
1991 RRC- never got a name- long since recycled
Reply With Quote
Old March 9th, 2015, 11:39 AM
JSBriggs's Avatar
Status: Online
Jeff Briggs
Antarctic Blue Super Sports Wagon
Site Team
Join Date: Nov 2003
Location: Auburn CA
Posts: 12,194
You can expand the terminal on the wire with some needle nose pliers.


Originally Posted by sonoronos View Post
sheisters gonna sheist
Reply With Quote
Old March 9th, 2015, 04:06 PM
emah's Avatar
Status: Offline
Ed Mah
1993 NAS D110
Join Date: Jul 2004
Location: San Diego, CA USA
Posts: 194
Thanks again guys for all your help. I will try to fix that connection later.

Reply With Quote

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

110, nas, nas 110, snorkel, start

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Won't start after after torrential downpour?! jijalicious Defender Technical Discussions 51 November 10th, 2011 12:17 PM
Truck won't start after washing...Please Help!!! jefhuf Defender Technical Discussions 34 July 24th, 2010 11:43 AM
Won't start after short trips 61rover Defender Technical Discussions 7 April 5th, 2009 06:49 AM
Won't Start After CB Install floyd650 Defender Technical Discussions 7 December 8th, 2008 06:18 PM
d90 won't start after pressure washing Bruce Brown Defender Technical Discussions 13 January 23rd, 2007 09:48 AM

All times are GMT -5. The time now is 02:36 PM.