Mysterious No-Start - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old May 11th, 2012, 10:05 AM
mattwhite
Status: Offline
Matt White
94 D-90
Member
 
Join Date: Sep 2003
Location: Fort Collins, CO
Posts: 116
Mysterious No-Start

So a couple of weeks ago the 90 would not fire up. I popped the hood and checked for spark, no spark. I pulled the ignition fuse and it looked fine, but I swapped it with the A/C fuse anyways. The truck fired up on the first crank and the A/C still worked. Oh well at least it starts.

Since then its happened a few more times. Each time if I pull the ignition fuse and put it back in, the truck will turn over on the next crank.

Any ideas? Am I resetting the ignition when I pull the fuse?

Matt
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old May 11th, 2012, 10:10 AM
carlosz's Avatar
carlosz
Status: Offline
Carlos
frank stein "frankie" in action RIP
Member
 
Join Date: Jun 2006
Location: east coast
Posts: 962
Registry
no, you may have a loose contact on said fuse port, i suggest taking a second look at it....
Reply With Quote
  #3  
Old May 11th, 2012, 04:11 PM
mattwhite
Status: Offline
Matt White
94 D-90
Member
 
Join Date: Sep 2003
Location: Fort Collins, CO
Posts: 116
I was definitely going to start there. I wanted to see if anyone had some other conspiracy theories.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old May 13th, 2012, 09:07 AM
Rocky's Avatar
Rocky
Status: Offline
Chris
72 + D1 drivetrain
Member
 
Join Date: Sep 2006
Location: Colonies Aka Boston
Posts: 8,771
Maybe a little lite cleaning of the contacts
__________________
A friend of mine runs a land rover / range rover specialty repair shop. Based on his experience, they are capable of stopping anywhere, anytime, at any cost.

I don't know about the brakes, only their unreliability.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
start

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Truck will not START ? Weldon Defender Technical Discussions 28 December 15th, 2005 12:58 PM
HELP 94 d90 will not start ripp2002 Defender Technical Discussions 64 August 25th, 2005 08:43 AM
95 won't start, possible fuel priming issue? jcasteel Defender Technical Discussions 1 March 15th, 2005 09:45 AM
Rats! Now my D90 won't start. No power to fuel pump jcasteel Defender Technical Discussions 8 March 15th, 2005 09:42 AM
Non D90 Technical Question jump start polarity problem dnewman9 Defender Technical Discussions 4 September 6th, 2004 05:39 AM


All times are GMT -5. The time now is 10:42 PM.


Copyright