Major Wire problem-- dash dissasembly. Need help. Ignition Mallory Unilite - Page 2 - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #21  
Old August 13th, 2007, 10:13 AM
vesparover's Avatar
vesparover
Status: Offline
brian bertolini
Member
 
Join Date: Sep 2003
Location: charleston, sc
Posts: 152
Wouldn't you know that I'm having the exact same problem. I have a gm hei dizzy that keeps blowing the module. The ignition light is on now and I'm thinking either the switch or wiring. Have you made any headway? The idea of using the current ignition lead to power a relay makes sense as a temp solution. When I replace the module it will fire right up but once I shut the truck down- bye bye module. Let me know what's up with your fix heath.
brian bertolini
Reply With Quote
Sponsored Links
Advertisement
 
  #22  
Old August 13th, 2007, 10:16 AM
Heath's Avatar
Heath
Status: Offline
Heath Ahrens
1995/D-90
Member
 
Join Date: Feb 2004
Location: Bernardsville, NJ, US
Posts: 125
I am going to try and work on it today. I will post my results.
I will be away for about 2 weeks so I will try to post something before I leave.
I am at the same place where I left off...
I am hesitating to take apart the whole dash when it might be something else.
-Heath
Reply With Quote
  #23  
Old August 29th, 2007, 12:35 PM
Heath's Avatar
Heath
Status: Offline
Heath Ahrens
1995/D-90
Member
 
Join Date: Feb 2004
Location: Bernardsville, NJ, US
Posts: 125
Well, I just got back on Sunday and I have been working on the truck the whole day.
I seem to have some sort of a short.
I removed the negative side of the battery and a test light lights up between the ground cable and the post. I started removing fuses and it seems that the Hazard fuse makes the light go off.
Also the radio fuse popped when I was messing with this.
Maybe the radio is wired improperly?

I tried testing the new Unilite module which tested properly for a minute and then popped.
(you can actually hear a popping sound when it goes)

This is killing me.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
dash

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mallory Hyfire 6EZ Ignition CDeWan For Sale - Parts 2 February 3rd, 2009 02:48 PM
Dash, Running & Head light PROBLEM ! Weldon Defender Technical Discussions 5 November 9th, 2005 02:04 PM
Mallory Unilite Distributor Davis Defender Technical Discussions 5 April 9th, 2005 05:00 PM
Ignition Problem Dfndr90 Defender Technical Discussions 1 November 21st, 2004 08:26 PM
ignition problem Irish1 Defender Technical Discussions 4 July 24th, 2004 09:41 PM


All times are GMT -5. The time now is 06:10 AM.


Copyright