Loss of power - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old August 16th, 2004, 09:26 PM
Leadfoot
Status: Offline
Mark Armstrong
Member
 
Join Date: Aug 2004
Location: Oakville, Ontario, Canada
Posts: 1
Loss of power

I am looking for a little direction in solving the following problem ('94 D90 3.9 North American Spec).



Recently I have had a problem with loss of engine power while driving (It is not a sputtering, this is a total loss of engine) Sometimes as I am coasting down, the engine starts running again. Sometimes it cuts out and stalls. Then, a minute later, without doing anything it starts up as if noting has happened.



During this loss of power, the radio works (so I have some electrical power). The temperature of truck if normal, and outside temperature is 20 Celsius and it is not been driven hard at all just cruising at 80kmph.



If someone could start me with the order of things to check/replace (with costs in mind) I would appreciate it very much. (i.e. fuel relay, fuel pump, coil etc....)



Thanks
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old August 17th, 2004, 12:20 AM
Roadsiderob's Avatar
Roadsiderob
Status: Offline
Robert Dassler
1994 D90
D-90 Source Vendor
 
Join Date: Apr 2004
Location: Albuquerque, NM, USA
Posts: 994
Mark,
I'd start by checking the connections at the ignition coil...the original spade connections get dirty and loose and can cause the problem you have. The generally accepted repair is to cut off the spade connectors and crimp and solder on some ring terminals and bolt them solidly to the coil.
Rob
Reply With Quote
  #3  
Old January 28th, 2005, 03:01 AM
arbik
Status: Offline
Arbi Karapetian
1995 D-90 SW #163/500
Member
 
Join Date: Jan 2005
Location: La Crescenta, CA, USA
Posts: 175
Did you get figure out what the problem was?

Leadfoot,

did you figure out what the problem was?

-arbi

Quote:
Originally Posted by Leadfoot
I am looking for a little direction in solving the following problem ('94 D90 3.9 North American Spec).



Recently I have had a problem with loss of engine power while driving (It is not a sputtering, this is a total loss of engine) Sometimes as I am coasting down, the engine starts running again. Sometimes it cuts out and stalls. Then, a minute later, without doing anything it starts up as if noting has happened.



During this loss of power, the radio works (so I have some electrical power). The temperature of truck if normal, and outside temperature is 20 Celsius and it is not been driven hard at all just cruising at 80kmph.



If someone could start me with the order of things to check/replace (with costs in mind) I would appreciate it very much. (i.e. fuel relay, fuel pump, coil etc....)



Thanks
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old January 28th, 2005, 01:38 PM
Hans's Avatar
Hans
Status: Offline
Hans Haase
The D-90.com Lab Rat
Member
 
Join Date: Oct 2003
Location: Long Island, NY
Posts: 2,381
Also check the fuse for the Fuel Pump. Mine was badly corroded for some reason, which caused intermittant total shutdown.

Oh, and when was the last time you changed the fuel filter?

-Hans
__________________
My oil line fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
My 100k stopped odometer fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Brace for impact, I'm in a "modifying mood". Massive thread count inbound.
Reply With Quote
  #5  
Old January 28th, 2005, 03:36 PM
arbik
Status: Offline
Arbi Karapetian
1995 D-90 SW #163/500
Member
 
Join Date: Jan 2005
Location: La Crescenta, CA, USA
Posts: 175
Thanks for the info Hans. I just picked up the rig, and had this happen to me once. I'm taking it back to the dealership, but just wanted to see if it was something simple.

I'll have to check the fuses and have them change the fuel filter too.

-arbi
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
300 Tdi Egt Q?????? Buckon37s Defender Technical Discussions 37 July 11th, 2012 11:26 AM
HS2.8TGV Severe power loss. Air in fuel line? DesertRat Defender Technical Discussions 12 February 24th, 2007 08:35 AM
Strange loss of power... OCD90 Defender Technical Discussions 3 September 7th, 2004 05:32 PM
Power loss and popping! TwisteD90 Defender Technical Discussions 40 May 30th, 2004 12:45 PM
Power Windows (was: Leccy Windows!!!!!) P1CR Defender Technical Discussions 21 February 28th, 2004 01:14 PM


All times are GMT -5. The time now is 06:35 PM.


Copyright