Lights out!! - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old May 10th, 2006, 08:31 PM
bjenk
Status: Offline
Brian Jenkinson
1994 D90
Member
 
Join Date: Oct 2004
Location: morrison, colorado, usa
Posts: 158
Lights out!!

i was pulling a trailer and my guage and parking lights went out. I assumed that I blew a fuse, because the trailer has parking lights on the side. I checked the fuse, but it is still good. anyone happen to have a similar problem with a solution?

just check and I do not have brake lights either, I do have signal lights.

any help is always appreciated.

brian
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old May 10th, 2006, 09:13 PM
scoloco's Avatar
scoloco
Status: Offline
Scott
'94 D90 ST
Member
 
Join Date: Jan 2004
Location: Manchester NH
Posts: 372
did you check both fuses? my truck is fused left/right wrt parking lights. the trailer wiring deal was installed (its a cockup) and buggered something coz its no longer right/left its left+rear/rightfront. Needless to say I blew that one 5a fuse whenever I plugged the trailer in. Upped it to a 10a fuse. ymmv.
Reply With Quote
  #3  
Old May 10th, 2006, 10:26 PM
bjenk
Status: Offline
Brian Jenkinson
1994 D90
Member
 
Join Date: Oct 2004
Location: morrison, colorado, usa
Posts: 158
I checked all fuses and they were all good. I will have to wait until I get home to check a wiring diagram.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old May 10th, 2006, 10:45 PM
Hans's Avatar
Hans
Status: Offline
Hans Haase
The D-90.com Lab Rat
Member
 
Join Date: Oct 2003
Location: Long Island, NY
Posts: 2,381
Did you check the under-hood maxi-fuses as well?

-Hans
__________________
My oil line fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
My 100k stopped odometer fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Brace for impact, I'm in a "modifying mood". Massive thread count inbound.
Reply With Quote
  #5  
Old May 11th, 2006, 01:08 AM
bjenk
Status: Offline
Brian Jenkinson
1994 D90
Member
 
Join Date: Oct 2004
Location: morrison, colorado, usa
Posts: 158
Checked the four fuses (large fuses) and all are ok. I am at a lost on what could have blown. Could have the switch blown? Is there a relay between?
Reply With Quote
  #6  
Old May 11th, 2006, 09:31 AM
Mike Hippert's Avatar
Mike Hippert
Status: Offline
D-90Slut/Stalker,SNLPres
94 D-90 Grinding Rover
Member
 
Join Date: Sep 2003
Location: Manchester NH USA
Posts: 4,789
I would suspect the headlight switch, they are known to be problematic.
__________________
Don't forget to
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
first then ask questions later! The loose nut behind the wheel
Reply With Quote
  #7  
Old May 11th, 2006, 10:54 AM
Weldon's Avatar
Weldon
Status: Offline
Weldon Pundt
"95" D-90
Member
 
Join Date: Oct 2003
Location: Charleston, SC
Posts: 266
I had a similar issue, head lights only worked in high beam settings, then my truck would not start had it towed to shop, shop could not find problem, I thought it was fule pump causing it not to start ?

Shop said it can't be fule pump, so I held them off from replacing fule pump so I could replace the 2 relays under passenger seat & by replacing both relays this solved both problems (head light issue & starting issue)...

If you replace them make sure you get the correct relays, I purchase alternate relays that I was told they will work, nope no work, so make sure you get the "Bosch" if you do this...
__________________
Thanks
Weldon
Reply With Quote
  #8  
Old May 12th, 2006, 12:54 AM
bjenk
Status: Offline
Brian Jenkinson
1994 D90
Member
 
Join Date: Oct 2004
Location: morrison, colorado, usa
Posts: 158
Problem solved. I rechecked all the fuses and found the 5 amp fuse blown. I now have to put the dash together again. I don't know how I missed it though. Thanks everyone.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
ht, lights

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tail Light Boot Installation - Fixing Hosed Tail Lights JimC Misc. Chit-Chat 1 July 11th, 2017 04:14 PM
Hinged fog lights. rustydefender Defender Technical Discussions 2 February 28th, 2005 09:33 PM
flickering lights nykx Defender Technical Discussions 1 November 12th, 2004 06:10 PM
Back lights all out vnrover Defender Technical Discussions 7 June 21st, 2004 12:04 AM
Hella 4000 lights Nigel Buchan For Sale - Parts 4 November 26th, 2003 09:47 PM


All times are GMT -5. The time now is 12:18 AM.


Copyright