Intreior Light Problem - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old November 5th, 2004, 06:33 PM
proulx70's Avatar
proulx70
Status: Offline
Paul S.
1997 NAS BRG Soft-Top
D-90 Source Vendor
 
Join Date: Nov 2003
Location: Studio City, CA
Posts: 216
Intreior Light Problem

The interior light on my '97 ST is supposed to come on when I open the door with the switch set in the middle. This does not work. I have to flick the switch either front or back to get it on. Occasionally, the auto-off/on switch will work with the switch set closest to the passengers. Quick fix? I pulled the light out and see the simple contact it makes from front to back, but can't seem to get it going.

BTW, the couple of times it worked I noticed the light has a dimming feature when you close the door. I find it funny that on such a utilitarian truck with manaual levers/switches. etc, that it would have this soft, mellow, luxurious dim feature on the light. Am I the only one amused by this?

Cheers,

Paul
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old November 5th, 2004, 07:23 PM
javelinadave
Status: Offline
-
-
Member
 
Join Date: Sep 2003
Location: -
Posts: 5,394
I had the same problem when I got my 97-ST. Push the plunger in and spray in some contact cleaner. Then tighten the screw(s) that hold the switch in place. It is a very cheesy way that LR used to ground it but the loose screws will cause the light not to work.
If you are still having trouble, pull off the panel in the middle of your parcel tray. Check to see that both plugs are plugged in securely to the module that is attached to the panel. Good luck and let us know if it helped.....
Reply With Quote
  #3  
Old November 11th, 2004, 03:43 AM
proulx70's Avatar
proulx70
Status: Offline
Paul S.
1997 NAS BRG Soft-Top
D-90 Source Vendor
 
Join Date: Nov 2003
Location: Studio City, CA
Posts: 216
Worked like a charm.

Thanks much!

Paul
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old February 7th, 2007, 05:30 PM
GYM's Avatar
GYM
Status: Offline
Gary
97 SW
Member
 
Join Date: Jul 2006
Location: West Coast
Posts: 1,062
I have the opposite problem. The interior light turns on fine, but sometimes the dimmer works and light goes out in a few seconds, sometimes it doesn't. It does not time out and turn off after a few minutes, either. It stays on indefinitely. Does not matter if truck is running or not, in Park or Neutral, ignition on or off, rainy or dry, doors open or closed. The problem occurs on a (seemingly)random basis.

Module was replaced a little over a year ago, but due to the random nature of the problem, it was difficult to see if that helped. Light unit itself works fine switching on and off manually. I've replaced both door jamb switches ('97 ST), and have no other electrical gremlins at the moment. Am now wondering if replacement module is bad and am tempted to swap out the module from my SW, (which works perfect) to test it. Do you guys have any ideas what else problem could be? (some sort of ground issue, bad switch in the light itself?) How would I diagnose?
Any help sincerely appreciated. Thanks.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
ht

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wobbly distributor cap? and an update on my starter problem MiniGuy Defender Technical Discussions 6 January 10th, 2006 10:13 AM
Air Locker problem sflash868 Defender Technical Discussions 1 May 9th, 2005 09:40 AM
Ignition Problem Dfndr90 Defender Technical Discussions 1 November 21st, 2004 08:26 PM
Fun new problem: starter circuit issue jaherring Defender Technical Discussions 1 September 12th, 2004 03:07 AM
on-going electrical problem... vesparover Defender Technical Discussions 3 October 23rd, 2003 11:13 AM


All times are GMT -5. The time now is 10:47 AM.


Copyright