Intermitent Starting Problem - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old July 27th, 2006, 11:30 AM
97D90's Avatar
97D90
Status: Offline
Andrew Walcker
1997 Defender 90 LE
Member
 
Join Date: Aug 2005
Location: SoCal
Posts: 169
Intermitent Starting Problem

I did a search but didn't find a problem like I'm experiencing!

I have a 1997 Defender 90 with 113K miles. The ignition was replaced with a brand new one 6 months back. It does have an aftermarket alarm with an engine kill.

The problem is that somtimes, could be one month or one week between occurences, the D won't start. I will insert the key and turn, everything works (all dash lights kick on, radio, lights, fuel pump, dome lights, etc) but there will be NO sound from the starter. The engine will not even try to turn over. I typically experience this on warmer days after driving for at least 20 minutes and say, pulling over to get gas or going to fast food. If I jump back in a few minutes later, no start! Sometimes it takes 30 minutes, somtimes 2 hours and than it starts like nothing was ever wrong. The other day I had to get it flatbedded back to my house after fooling around for 90 minutes in the Chevron gas line. The tow truck driver dropped the D-90 at my house and for fun I jumped in, turned the key and it started right up! Talk about an embarrasing moment, luckily the tow truck driver had tried to start it also at the Chevron or I really would have felt like an idiot.

I've had Inland Rovers go over it multiple times, and of cours it will not do it when it's there! The D is not throwing any codes. I'm to the point were I'm thinking of tearing the alarm out, replacing the two realays under the seat, replacing the alternator and anything else that is in line. Of course this approach is not the wisest way to throw cash away, so I'm looking for any words of wisdom. Any help is appreciated!

If I blew my search please direct me to the link and I will humbly take any tongue lashings that may follow
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old July 27th, 2006, 11:46 AM
Billakris's Avatar
Billakris
Status: Offline
Kris
Alpine White 95 Soft Top
Member
 
Join Date: Sep 2003
Location: Kansas City/ Manhattan, KS
Posts: 271
Check to make sure the little box (i think its called the starter module) which should be next to the coil if its like a 95, is securely attached to the mounting bracket. Mine was loose and I had similar problems. Put some dielectric grease between the plate and the back of the box to prevent a short.

This is assuming the 97 is like a 95...
__________________
Kris
Reply With Quote
  #3  
Old July 27th, 2006, 11:54 AM
Mike Hippert's Avatar
Mike Hippert
Status: Offline
D-90Slut/Stalker,SNLPres
94 D-90 Grinding Rover
Member
 
Join Date: Sep 2003
Location: Manchester NH USA
Posts: 4,789
97's are a bit different Kris.

So no engine codes then right? Do you hear the fuel pump comming on? How old is the fuel filter?
__________________
Don't forget to
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
first then ask questions later! The loose nut behind the wheel
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old July 27th, 2006, 11:57 AM
Billakris's Avatar
Billakris
Status: Offline
Kris
Alpine White 95 Soft Top
Member
 
Join Date: Sep 2003
Location: Kansas City/ Manhattan, KS
Posts: 271
My bad...
__________________
Kris
Reply With Quote
  #5  
Old July 27th, 2006, 11:58 AM
97D90's Avatar
97D90
Status: Offline
Andrew Walcker
1997 Defender 90 LE
Member
 
Join Date: Aug 2005
Location: SoCal
Posts: 169
No codes, I can hear the fuel pump and I think the fuel filter was switched about a year ago.
Reply With Quote
  #6  
Old July 27th, 2006, 01:29 PM
ECR's Avatar
ECR
Status: Offline
East Coast Rover Co.
Just Defenders, nothing else.
D-90 Source Vendor
 
Join Date: May 2006
Location: Rockland, ME, USA
Posts: 4,614
Iffy starter relay?
Iffy ignition switch??
Iffy park/ starter inhibt switch???
__________________
Email:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

I do not check PMs. Call or email if you need something.

ECR is not a parts source. We are not in the mail order business.
Reply With Quote
  #7  
Old July 27th, 2006, 08:19 PM
97D90's Avatar
97D90
Status: Offline
Andrew Walcker
1997 Defender 90 LE
Member
 
Join Date: Aug 2005
Location: SoCal
Posts: 169
Thanks for everyone's input! I'm going to have the alarm's engine kill relay bypassed and than look into the starter relay.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
start, starting

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting problem (occassionally) kolvedic Defender Technical Discussions 21 January 21st, 2012 11:12 AM
Electrical starting problem JKC Defender Technical Discussions 14 September 8th, 2009 09:20 AM
Interesting starting problem kolvedic Defender Technical Discussions 3 December 12th, 2008 06:12 PM
Help! Problem starting (95 SW) reaper99999 Defender Technical Discussions 8 March 2nd, 2006 07:22 PM
Fun new problem: starter circuit issue jaherring Defender Technical Discussions 1 September 12th, 2004 03:07 AM


All times are GMT -5. The time now is 10:11 PM.


Copyright