Installed Momo wheel and hub, now have clicking noise whenever wheel turns - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old August 29th, 2013, 11:26 AM
bradfordish's Avatar
bradfordish
Status: Offline
Bradford
95 D90 SW #141
Member
 
Join Date: May 2013
Location: Scarif
Posts: 421
Registry
Installed Momo wheel and hub, now have clicking noise whenever wheel turns

I recently installed a momo steering wheel (wanted something smaller) and the #5607 hub. Ever since then, I have a clicking/noise whenever I turn the wheel in either direction. It's not just once, the more I turn it will click/crunch again, and then when it turns back. It sounds like it may be coming from the signal lever. I have taken the hub off, check it out and reinstalled and the noise persists. Thoughts? At this point I'm likely going back to my stock wheel as this is driving me crazy.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old August 29th, 2013, 05:21 PM
Hoosier's Avatar
Hoosier
Status: Offline
Chris Hinkle
More than I need
Member
 
Join Date: Jun 2006
Location: Dallas, TX
Posts: 634
Check to see if the Momo adapter is touching the plastic surround/fascia. Where the surround comes together is a seam of plastic that may have to be ground down. The tab on the hub does sit inside the little blue ring for the turn signal cancellation, but really shouldn't make any noise. I did have to shorten a tab once because it was too long for the blue ring.
__________________
____________________
Chris Hinkle
Current project - D110 with extended cab and LS3
Reply With Quote
  #3  
Old August 30th, 2013, 03:26 PM
bradfordish's Avatar
bradfordish
Status: Offline
Bradford
95 D90 SW #141
Member
 
Join Date: May 2013
Location: Scarif
Posts: 421
Registry
I shaved down the plastic surround prior to the original install and it doesn't look like it is touching.... guess I'm going to need to shorten the hub tab.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old August 31st, 2013, 08:38 AM
Hoosier's Avatar
Hoosier
Status: Offline
Chris Hinkle
More than I need
Member
 
Join Date: Jun 2006
Location: Dallas, TX
Posts: 634
When I used a RR adapter on my defender - the tab broke off when I tightened it down. But there is a fix for that.
__________________
____________________
Chris Hinkle
Current project - D110 with extended cab and LS3
Reply With Quote
  #5  
Old September 1st, 2013, 03:21 PM
CDeWan
Status: Offline
Clay DeWan
5.3L beastie
Member
 
Join Date: Feb 2008
Location: Raleigh, NC
Posts: 3,493
Doesn't your mono have a molded turn signal reset ring? If so that may need to be shaved
Reply With Quote
  #6  
Old September 3rd, 2013, 10:34 AM
bradfordish's Avatar
bradfordish
Status: Offline
Bradford
95 D90 SW #141
Member
 
Join Date: May 2013
Location: Scarif
Posts: 421
Registry
Ended up shaving down the plastic bezel and breaking off the turn signal reset ring. Much better but still some noise when the wheel is turned enough for a u-turn. I've also noticed that my horn and flash high beams no longer work. Checked the fuse which was fine, could the steering wheel have messed up the turn signal/horn/lights switch?
Reply With Quote
  #7  
Old September 3rd, 2013, 10:39 AM
Uncle Douglas's Avatar
Uncle Douglas
Status: Offline
Doug Crowther
A defender in every driveway-motto
D-90 Source Vendor
 
Join Date: Dec 2007
Location: Gods Country- Central Virginia
Posts: 11,839
Registry
if I'm reading this right and you broke off the blue turn signal reset ring its a very good change you broke that multi switch which is your horn,turn signals, and dimmer switch. Why would you break that ?
__________________
Good judgement comes from experience,experience comes from bad judgement.

Dividing Creek Imports
Worldwide Vehicle Shipment and Importation Service
Restoration & Modification work


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

410.693.1391


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #8  
Old September 3rd, 2013, 10:40 AM
bradfordish's Avatar
bradfordish
Status: Offline
Bradford
95 D90 SW #141
Member
 
Join Date: May 2013
Location: Scarif
Posts: 421
Registry
I didn't break the blue ring, I broke the tab off the momo hub trying to shorten it. The blue ring does seem to move independently though, is this normal?
Reply With Quote
  #9  
Old September 3rd, 2013, 07:46 PM
Uncle Douglas's Avatar
Uncle Douglas
Status: Offline
Doug Crowther
A defender in every driveway-motto
D-90 Source Vendor
 
Join Date: Dec 2007
Location: Gods Country- Central Virginia
Posts: 11,839
Registry
independently ? its supposed to float and just rides on the tab of the steering wheel. If it gets off center the turn signal stalk wont lock into position on the side it falls to which can be annoying. Strange you lost all function from that stalk. Any chance the plug may have come apart ?
__________________
Good judgement comes from experience,experience comes from bad judgement.

Dividing Creek Imports
Worldwide Vehicle Shipment and Importation Service
Restoration & Modification work


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

410.693.1391


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
wheel

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Momo Steering Wheel Hub Adapter Doug Crowther For Sale - Parts 10 November 7th, 2007 06:34 PM
Momo Wheel and Hub Adaptor Bozman Defender Technical Discussions 4 September 25th, 2006 10:30 AM
Momo Hub Adapter mchombeau Wanted 0 May 3rd, 2005 09:40 PM
another momo hub adapter question dnewman9 Defender Technical Discussions 0 October 3rd, 2004 08:46 PM
Hub Bolts kellymoe Defender Technical Discussions 9 September 17th, 2004 10:38 PM


All times are GMT -5. The time now is 04:13 PM.


Copyright