indicators - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old January 28th, 2008, 06:47 AM
jimmy salmon's Avatar
jimmy salmon
Status: Offline
jimmy salmon
94 D90 AA Yellow
Member
 
Join Date: Jun 2004
Location: Methuen MA USA
Posts: 1,342
indicators

since changing my indicators from the bumper to the side lights they flash ten to the dozen (fast). all bulbs are working, they are still the ligh bulbs, which part # bulb do i need to use, iv'e tried a few but none seem to work.
__________________
3rd low and BOOT IT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old January 28th, 2008, 09:00 AM
Abrooks's Avatar
Abrooks
Status: Offline
Tony Brooks
.
Member
 
Join Date: Oct 2003
Location: Arlington, VA
Posts: 4,927
You may want to try the archives on this -- I remember it being a big topic several years ago (2000/2001?) when a lot of '94 owners started putting on after market bumpers. If I remember correctly (which is doubtful) you can get away with using the bulb and lens from a '97 -- at least that's how I seem to remember doing it. I'm sure plenty of people will chime in, though.
Reply With Quote
  #3  
Old January 28th, 2008, 12:46 PM
Uncle Douglas's Avatar
Uncle Douglas
Status: Offline
Doug Crowther
A defender in every driveway-motto
D-90 Source Vendor
 
Join Date: Dec 2007
Location: Gods Country- Central Virginia
Posts: 11,844
Registry
Jimmy,

Let me know what you find out, mine does the same thing.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old January 28th, 2008, 01:41 PM
ini88's Avatar
ini88
Status: Offline
Daniel Marcello
Alloy+Grit Creative Director
Member
 
Join Date: Aug 2005
Location: Queens, NY
Posts: 2,816
Are you guys talking about moving the blinkers from the bumper to the front bezel where the parking and headlights are? Or moving them to the side light on the fender?

Moving lights from Bumper to Bezel:
I moved mine from the bumper to the front bezel and they work perfectly. I used a Series III rear brake light as the housing unit and replaced it with a double filament light for the two actions of 'blinking' and 'on' state when the headlights are turned on. You throw out the red lens and replace it with a yellow lens. fits perfect and flashes perfect.
__________________
1955 Series I
1975 FC101 Vampire
1994 Defender 90 #916
1967 Lancia Fulvia
1974 Alfa Romeo GTV
Reply With Quote
  #5  
Old January 28th, 2008, 01:59 PM
jimmy salmon's Avatar
jimmy salmon
Status: Offline
jimmy salmon
94 D90 AA Yellow
Member
 
Join Date: Jun 2004
Location: Methuen MA USA
Posts: 1,342
moving indicators from bumper to bezel and using one of the side/parking lights
__________________
3rd low and BOOT IT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #6  
Old January 28th, 2008, 02:11 PM
ECR's Avatar
ECR
Status: Offline
East Coast Rover Co.
Just Defenders, nothing else.
D-90 Source Vendor
 
Join Date: May 2006
Location: Rockland, ME, USA
Posts: 4,614
We use the same things as ini88 listed above on the early 94 (white lamp base). The later 94s (black base lamp) you can use the rear amber lens from a Euro 110 and a different bulb and it plugs in and flashes right.

Something I haven't tried but should work in theory is using the new variable load flashers like is used in an LED kit. These should stabilize the flash rate as they do not look at the "load" like the factory flasher units do.
__________________
Email:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

I do not check PMs. Call or email if you need something.

ECR is not a parts source. We are not in the mail order business.
Reply With Quote
  #7  
Old January 28th, 2008, 10:44 PM
cgalpin's Avatar
cgalpin
Status: Offline
Charles Galpin
'94 D90 ST, '63 SeriesIIA
Site Team
 
Join Date: Jan 2004
Location: South Riding, VA
Posts: 11,625
Registry
Let me know how it goes Jimmy. Mine has been like that since I got it. Never annoyed me until I got the 110 (which blinks correctly). Now it drives me nuts.
Reply With Quote
  #8  
Old January 28th, 2008, 11:11 PM
themaxx's Avatar
themaxx
Status: Offline
Ade
94 ST
Member
 
Join Date: Aug 2006
Location: MD
Posts: 1,835
Registry
Pics please...
__________________
"It insists upon itself" Family Guy
"Your Defender insists upon itself" Dave Parker
Reply With Quote
  #9  
Old January 29th, 2008, 04:19 AM
Gren_T's Avatar
Gren_T
Status: Offline
Gren Thomas
1985 90 300tdi auto
Member
 
Join Date: Feb 2005
Location: bridgend, wales , UK
Posts: 413
HI Guys if i am reading the thread right the problem is the blinkers front and rear are different wattages from the side, the side blinker is a 5watt the main blinkers front and rear are 10Watt.

You will need the replace the bulbs with 10W types to get the correct flash rate, as ECR says an LED flasher will work but care is needed as some of the poor copy led flashers I have seen will not drive more than 10watts total as LEDs are low power consumption devices.

Regards

Gren
Reply With Quote
  #10  
Old January 29th, 2008, 08:45 AM
jimmy salmon's Avatar
jimmy salmon
Status: Offline
jimmy salmon
94 D90 AA Yellow
Member
 
Join Date: Jun 2004
Location: Methuen MA USA
Posts: 1,342
Quote:
Originally Posted by themaxx
Pics please...
bulb on , bulb off , bulb on .
__________________
3rd low and BOOT IT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #11  
Old January 29th, 2008, 10:30 AM
themaxx's Avatar
themaxx
Status: Offline
Ade
94 ST
Member
 
Join Date: Aug 2006
Location: MD
Posts: 1,835
Registry
Come on...I'm visual guy.
Quote:
Originally Posted by jimmy salmon
bulb on , bulb off , bulb on .
__________________
"It insists upon itself" Family Guy
"Your Defender insists upon itself" Dave Parker
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Indicators stopped working ... leastonce Defender Technical Discussions 1 November 2nd, 2009 10:25 AM
Turn indicators landrovered Defender Technical Discussions 1 August 31st, 2007 01:33 PM
HELP! Indicators, Dash, Electrical Problems minorthreat Defender Technical Discussions 3 April 11th, 2007 09:19 PM
Euro style front turn indicators boshea Defender Technical Discussions 12 September 22nd, 2005 07:56 AM
indicator's rover4x4 Defender Technical Discussions 0 October 27th, 2003 03:02 PM


All times are GMT -5. The time now is 08:20 AM.


Copyright