Ignition Power - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old November 22nd, 2004, 09:18 AM
bjenk
Status: Offline
Brian Jenkinson
1994 D90
Member
 
Join Date: Oct 2004
Location: morrison, colorado, usa
Posts: 158
Ignition Power

I don't have any power at my ignition switch, turn the key nothing. My dash is in pieces (cleaning/maintance). I am a new owner and was wondering about the workshop manuel CD that is on ebay. Does anyone have this CD and does it give a good wiring diagram?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old November 22nd, 2004, 09:27 AM
Mike Hippert's Avatar
Mike Hippert
Status: Offline
D-90Slut/Stalker,SNLPres
94 D-90 Grinding Rover
Member
 
Join Date: Sep 2003
Location: Manchester NH USA
Posts: 4,789
Someone posted that they bought the CD and they were happy with it. Not sure that it had electrical diagrams though. does anything else work? Like the hazard lights or head lights? Did any fuses get blown?
__________________
Don't forget to
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
first then ask questions later! The loose nut behind the wheel
Reply With Quote
  #3  
Old November 22nd, 2004, 12:14 PM
bjenk
Status: Offline
Brian Jenkinson
1994 D90
Member
 
Join Date: Oct 2004
Location: morrison, colorado, usa
Posts: 158
Thanks Mike, I notice there is a lot of info about the cd-rom right now in this forum. I think I am going to pick one up. Yes, I have power to the lights, ect. However, I get nothing when the key is in the ignition.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old November 22nd, 2004, 12:38 PM
Mike Hippert's Avatar
Mike Hippert
Status: Offline
D-90Slut/Stalker,SNLPres
94 D-90 Grinding Rover
Member
 
Join Date: Sep 2003
Location: Manchester NH USA
Posts: 4,789
Hmmm, I had the same thing happen in Jimmy's 90, but it was the battery cable that came loose. If you don't get one by this weekend let me know and I'll e-mail you the wiring for the ignition.
__________________
Don't forget to
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
first then ask questions later! The loose nut behind the wheel
Reply With Quote
  #5  
Old November 22nd, 2004, 01:57 PM
bjenk
Status: Offline
Brian Jenkinson
1994 D90
Member
 
Join Date: Oct 2004
Location: morrison, colorado, usa
Posts: 158
Thanks Mike, my email is brianjenkinson@msn.com.
Reply With Quote
  #6  
Old November 22nd, 2004, 02:18 PM
Abrooks's Avatar
Abrooks
Status: Offline
Tony Brooks
.
Member
 
Join Date: Oct 2003
Location: Arlington, VA
Posts: 4,927
Fuse 5 (15 amp) powers the switch if that helps.
Reply With Quote
  #7  
Old November 22nd, 2004, 02:45 PM
bjenk
Status: Offline
Brian Jenkinson
1994 D90
Member
 
Join Date: Oct 2004
Location: morrison, colorado, usa
Posts: 158
Anthony, Thanks I will look tomorrow after work (24 hour schedule). I did not see any fuse labled ignition in the fuse box....FYI, I purchased a set of wing protectors for $99.99 from British Pacific, everywhere else it was over $200.00.
Reply With Quote
  #8  
Old November 22nd, 2004, 04:30 PM
Abrooks's Avatar
Abrooks
Status: Offline
Tony Brooks
.
Member
 
Join Date: Oct 2003
Location: Arlington, VA
Posts: 4,927
I *think* that fuse may be in the engine compartment against the bulkhead next to the clutch fluid resevoir. Maybe. I think.

(voltmeters are your friend with these trucks)

Good luck,

Tony
Reply With Quote
  #9  
Old November 22nd, 2004, 06:22 PM
bjenk
Status: Offline
Brian Jenkinson
1994 D90
Member
 
Join Date: Oct 2004
Location: morrison, colorado, usa
Posts: 158
Big fuse in the engine compartment labled ignition was good. I checked that yesturday. I have not gotten out my meter yet. Will spend some quality/quantity time tomorrow....
Reply With Quote
  #10  
Old November 22nd, 2004, 07:20 PM
Davis's Avatar
Davis
Status: Offline
Chris Davis
94 NAS D90 6.2LS
Member
 
Join Date: Nov 2003
Location: Colorado
Posts: 2,509
Could be the ignition switch--they have a history of going out. I just replaced mine last month.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
300 Tdi Egt Q?????? Buckon37s Defender Technical Discussions 37 July 11th, 2012 11:26 AM
Switch/Wiring Question: Stereo Ignition Power Override nimbusnic Defender Technical Discussions 3 June 30th, 2008 01:05 AM
Ignition? Trigger Defender Technical Discussions 12 August 1st, 2005 08:53 PM
Ford Duraspark replacement Ignition Control Module ICM jcasteel Defender Technical Discussions 0 June 7th, 2005 02:28 PM
Power Windows (was: Leccy Windows!!!!!) P1CR Defender Technical Discussions 21 February 28th, 2004 01:14 PM


All times are GMT -5. The time now is 05:33 PM.


Copyright