Idle Speed - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old November 23rd, 2008, 05:12 PM
kennybahr's Avatar
kennybahr
Status: Offline
Kenny Bahr
94 D90 Alpine White #1245
Member
 
Join Date: Oct 2007
Location: St. Louis, Missouri
Posts: 146
Idle Speed

I've started to notice when I start my 94 90 it idles at about 1500-2300 Rpm for a couple of seconds...then it goes down to normal, it's never done that before. Also when I shift, it idles at 1200 Rpm for a few seconds too...then it goes down to normal. Can anyone help me figure out what might be happening?

Thanks,
Kenny
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old November 23rd, 2008, 06:30 PM
Hans's Avatar
Hans
Status: Offline
Hans Haase
The D-90.com Lab Rat
Member
 
Join Date: Oct 2003
Location: Long Island, NY
Posts: 2,381
Unplug the battery or ECU lately?

-Hans
__________________
My oil line fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
My 100k stopped odometer fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Brace for impact, I'm in a "modifying mood". Massive thread count inbound.
Reply With Quote
  #3  
Old November 23rd, 2008, 10:06 PM
kennybahr's Avatar
kennybahr
Status: Offline
Kenny Bahr
94 D90 Alpine White #1245
Member
 
Join Date: Oct 2007
Location: St. Louis, Missouri
Posts: 146
No I have not unhooked the battery or the ECU, should I?
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old November 23rd, 2008, 10:09 PM
Hans's Avatar
Hans
Status: Offline
Hans Haase
The D-90.com Lab Rat
Member
 
Join Date: Oct 2003
Location: Long Island, NY
Posts: 2,381
Well, the symptoms you are describing are actually kinda normal to me. The ECU does increase the idle speed in certain situations to prevent stalling. But it can be more pronounced if your ECU has recently lost power and has to re-learn the idle curves.

It may also be a vacuum leak somewhere that has recently cropped up, and the stepper motor hasn't adjusted to it yet.

-Hans
__________________
My oil line fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
My 100k stopped odometer fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Brace for impact, I'm in a "modifying mood". Massive thread count inbound.
Reply With Quote
  #5  
Old November 23rd, 2008, 10:15 PM
kennybahr's Avatar
kennybahr
Status: Offline
Kenny Bahr
94 D90 Alpine White #1245
Member
 
Join Date: Oct 2007
Location: St. Louis, Missouri
Posts: 146
Quote:
Originally Posted by Hans
Well, the symptoms you are describing are actually kinda normal to me. The ECU does increase the idle speed in certain situations to prevent stalling. But it can be more pronounced if your ECU has recently lost power and has to re-learn the idle curves.

It may also be a vacuum leak somewhere that has recently cropped up, and the stepper motor hasn't adjusted to it yet.

-Hans
Hans, thank you for the quick reply! So with the above stated, everything should be probably be OK once the ECU relearns the idle cure?

Thanks
Kenny
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
idle

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
idle speed adjustment FlaD90 Defender Technical Discussions 15 July 23rd, 2012 12:32 PM
1997 D-90 Idle Speed ndhlp Defender Technical Discussions 4 October 11th, 2006 11:43 AM
Fault Code 48/fast engine idle speed arbik Defender Technical Discussions 9 June 2nd, 2006 07:02 AM
fluctuating idle KeithElisa Defender Technical Discussions 15 May 31st, 2006 08:38 AM
Code 48: Base Idle Speed? thug1313 Defender Technical Discussions 2 April 29th, 2005 11:52 PM


All times are GMT -5. The time now is 12:29 PM.


Copyright