I solved my stalling! - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old December 18th, 2012, 08:58 PM
wantone
Status: Offline
Rick Thompson
94 ST #1222
Member
 
Join Date: Aug 2009
Location: Omaha
Posts: 315
Registry
I solved my stalling!

I seem to have solved my ongoing mysterious stalling, sputtering etc i had spoken about in two previous threads. I replaced the ground w/a 1/0 battery ground from NAPA. I bolted it to the cross member, cleaned the bolts & all conact points on the frame, smeared dielectric grease on it. Then took a short cable from a winch & bolted it to the block & the frame.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old December 18th, 2012, 09:08 PM
rijosho's Avatar
rijosho
Status: Offline
Joshua
1995 Black ST - Rhinolined edition
Research Assistant/Eagle Eyes
 
Join Date: Apr 2009
Location: NYC
Posts: 16,557
Registry
Probably a better idea to update your other threads with the resolution than start a random new one, no?
__________________
Quote:
I am talking purely from an aesthetics standpoint.
Reply With Quote
  #3  
Old December 18th, 2012, 09:12 PM
leastonce's Avatar
leastonce
Status: Offline
Jason England
D-90 White 95 SW #65
Site Team
 
Join Date: Jul 2009
Location: NYC
Posts: 6,078
Registry
dude you missed the perfect lay up for a spot of irony ...
__________________
Quote:
Soapy water / KY jelly, etc. is is basically a must. Yes, good idea to remove trim panels - only takes 5 more minutes to do so.
Car Camping Collective founding member and Chief Executive Officer
Cat Camping Collective founding member and Chief Executive Officer
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old December 18th, 2012, 09:12 PM
wantone
Status: Offline
Rick Thompson
94 ST #1222
Member
 
Join Date: Aug 2009
Location: Omaha
Posts: 315
Registry
Good idea. I figured no one would read the ecu thread if they had stalling probs & if they saw this, maybe they would try this solution as it only cost $35. Rather than replacing the alt, stepper, ignition mod like i did. But i will update them.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
stalling bjenk Defender Technical Discussions 5 May 7th, 2005 12:56 AM
Stalling RR? headdamage Defender Technical Discussions 5 March 20th, 2005 12:29 AM
Stalling problem and fault codes James Defender Technical Discussions 5 July 22nd, 2004 07:29 PM
Turn signal--problem solved Davis Defender Technical Discussions 0 July 18th, 2004 08:13 PM
Why is my D90 stalling? JRowe Defender Technical Discussions 4 November 10th, 2003 04:17 PM


All times are GMT -5. The time now is 04:05 PM.


Copyright