Horn, wiper connection? - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Join the Defender Source Community Today

Thread Tools
Old July 4th, 2012, 01:20 PM
jayz's Avatar
Status: Offline
Jason Zolezzi
85 200tdi 110
Join Date: May 2011
Location: Walnut Creek, Ca
Posts: 779
Horn, wiper connection?

I took the lower dash off to get to the hazard problem but now the wipers and horn don't work. Is there a relay that runs those? I am going to take the instrument panel off to see if something came loose, just seems odd to me.

Reply With Quote
Old July 4th, 2012, 01:41 PM
Status: Offline
Marc-Andre Leger
94D90 CDN#18 http://rover.leger.ca
Join Date: May 2010
Location: Montreal, Quebec, Canada
Posts: 396
You must of unplugged the lever that operates these or have oxidation in the connector. Check and clean the contacts in the steering column. Other option is a fuse.
Reply With Quote

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
What makes the Rear Wiper park? COSteve Defender Technical Discussions 10 March 6th, 2007 04:40 PM
Locating the rear wiper pepstein Defender Technical Discussions 0 April 2nd, 2005 09:56 AM
Wiper Blades going haywire... arbik Defender Technical Discussions 4 February 22nd, 2005 11:07 PM
Wiper Motor HELP TDI Guy Defender Technical Discussions 1 June 13th, 2004 08:36 PM
bulkhead and wiper stud fitting problem mattdh Defender Technical Discussions 3 April 2nd, 2004 09:42 AM

All times are GMT -5. The time now is 04:23 AM.