Horn, wiper connection? - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old July 4th, 2012, 02:20 PM
jayz's Avatar
jayz
Status: Offline
Jason Zolezzi
85 200tdi 110
Member
 
Join Date: May 2011
Location: Walnut Creek, Ca
Posts: 776
Horn, wiper connection?

I took the lower dash off to get to the hazard problem but now the wipers and horn don't work. Is there a relay that runs those? I am going to take the instrument panel off to see if something came loose, just seems odd to me.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old July 4th, 2012, 02:41 PM
maleger
Status: Offline
Marc-Andre Leger
94D90 CDN#18 http://rover.leger.ca
Member
 
Join Date: May 2010
Location: Montreal, Quebec, Canada
Posts: 395
Registry
You must of unplugged the lever that operates these or have oxidation in the connector. Check and clean the contacts in the steering column. Other option is a fuse.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
horn

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What makes the Rear Wiper park? COSteve Defender Technical Discussions 10 March 6th, 2007 04:40 PM
Locating the rear wiper pepstein Defender Technical Discussions 0 April 2nd, 2005 09:56 AM
Wiper Blades going haywire... arbik Defender Technical Discussions 4 February 22nd, 2005 11:07 PM
Wiper Motor HELP TDI Guy Defender Technical Discussions 1 June 13th, 2004 09:36 PM
bulkhead and wiper stud fitting problem mattdh Defender Technical Discussions 3 April 2nd, 2004 09:42 AM


All times are GMT -5. The time now is 09:04 PM.


Copyright