horn not working - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old June 20th, 2008, 12:07 AM
whitelandy33
Status: Offline
Pecos
hyundai
Member
 
Join Date: Dec 2003
Location: Lucas, TX USA
Posts: 176
horn not working

When I push the stick in....no sound comes out.

Checked the dash/main fuses that are tied to horn. They are fine.

Is the horn located in the front right of engine bay? If so, i think eveything is connected. I guess the horn could go bad.

Any other ideas?

I did not see anything in the FAQs or previous posts.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old June 20th, 2008, 02:42 AM
oldscratchggf's Avatar
oldscratchggf
Status: Offline
nate
95 d90
Member
 
Join Date: Apr 2005
Location: california
Posts: 660
horns do go bad. both tones on mine died. cheap and easy to replace. front right of the engine bay. couple bolts, some plug and you're ready to play.
__________________
because six cylinders will take us farther than any president
Reply With Quote
  #3  
Old June 20th, 2008, 08:56 AM
NashvilleRover's Avatar
NashvilleRover
Status: Offline
Dendy Jarrett
2009 LR3- Well Built
Member
 
Join Date: Jun 2007
Location: Nashville, Tennessee - USA
Posts: 819
Want them to get out of your way? Try the Hella Super Horns (plug and play) available through Expedition Exchange (www.expeditionexchange.com)

They are relatively inexpensive as well.

Can you say L O U D!!

Dendy
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old June 20th, 2008, 09:02 AM
dmarchand's Avatar
dmarchand
Status: Offline
David Marchand
'97 D90 SW Arles
Member
 
Join Date: Sep 2003
Location: New England
Posts: 2,862
Registry
I have a set of year old hella replacement horns available (6 months of which the truck was in winter storage). $20 including shipping. I replaced mine with the supertones since drivers suck in Boston. These are a direct replacement.
Attached Thumbnails
Click image for larger version

Name:	IMG_0612.JPG
Views:	106
Size:	79.5 KB
ID:	13919   Click image for larger version

Name:	IMG_0611.JPG
Views:	126
Size:	94.7 KB
ID:	13920  

Click image for larger version

Name:	IMG_0610.JPG
Views:	88
Size:	94.8 KB
ID:	13921  
Reply With Quote
  #5  
Old June 20th, 2008, 10:20 AM
whitelandy33
Status: Offline
Pecos
hyundai
Member
 
Join Date: Dec 2003
Location: Lucas, TX USA
Posts: 176
I picked up a high and low horn from autozone this morning. Installed one of them and the horn still does not work.

Could it be the switch inside the steering column? I guess I should put a volt meter on the wires that connect to the horn and see if there is power.
Reply With Quote
  #6  
Old June 20th, 2008, 11:40 AM
Stmpede's Avatar
Stmpede
Status: Offline
Andrew Najarian
'93 NAS D110 #43
Member
 
Join Date: Mar 2007
Location: Jacksonville, FL
Posts: 2,459
that would be my guess. Those switches are pretty flaky.
__________________
"I have taken more good from alcohol than alcohol has taken from me." - Winston Churchill
Reply With Quote
  #7  
Old June 20th, 2008, 12:19 PM
whitelandy33
Status: Offline
Pecos
hyundai
Member
 
Join Date: Dec 2003
Location: Lucas, TX USA
Posts: 176
100 bucks. http://www.roverparts.com/Parts/PRC3875.cfm

It would be cheaper to buy a couple handheld air horns but that would not pass inspection. Any other sources?

Is this an easy install?
Reply With Quote
  #8  
Old June 21st, 2008, 04:55 PM
Chaucer
Status: Offline
Will
93 110 | 97 90
Member
 
Join Date: Oct 2003
Location: WA
Posts: 583
I wouldn't just go buy parts and swap them out...you should diagnose the issue by tracing the wire connections.

Does power get to both sides of the fuse?
Is power at the switch (before pushing it in)?
After pushing it in, does power get to the horn?

Check grounds also, I think each horn has it's own ground...
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
horn

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedometer not working mgrgpg Defender Technical Discussions 4 June 11th, 2009 07:27 PM
louder horn advice chirider Misc. Chit-Chat 9 April 8th, 2008 04:49 PM
My headlights are not working woldd90 Defender Technical Discussions 13 December 2nd, 2005 10:49 AM
'95 Factory Radio Fade/Treble/Bass Button Not Working gamberik Defender Technical Discussions 1 March 30th, 2005 01:05 PM
Fuses? Horn and clock... OCD90 Defender Technical Discussions 3 November 17th, 2003 06:05 PM


All times are GMT -5. The time now is 02:05 PM.


Copyright