High Idle after Highway Cruise + stalling - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old October 11th, 2006, 01:26 PM
cellulararrest's Avatar
cellulararrest
Status: Offline
Chris Snyder
1994 D90 #614 | '07 L322 SC
Member
 
Join Date: Feb 2006
Location: Newburyport, MA
Posts: 1,544
High Idle after Highway Cruise + stalling

So this past weekend I did a lot of highway driving in the 90. I noticed that after cruising at say 75-80 most of the time (with the top off of course. great fun) when I would pull to an exit, the idle would be high around 1000, 1,200rpm. It would lower after a little while but I just thought it was a bit strange. Is this an indicator of something sticking? I'd like to catch it before it becomes a problem.

Also my truck has lost power and won't idle on two occassions now. It seems to be unrelated to anything. I get no check engine light. If I pull over and shut the ignition off then start the truck right back up everything is fine. Has anyone had this happen to them? I cannot find anything to connect it to, but I thought I would ask and see if anyone has any ideas.

One time is happened when it was pouring rain out and I thought the ECU might've gotten wet, but it started right back up like nothing ever happened.

Thanks for any help!
Chris
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old October 11th, 2006, 02:13 PM
jimngo's Avatar
jimngo
Status: Offline
Jim Ngo
1994 D90 #80
Member
 
Join Date: Aug 2006
Location: Salt Lake City, UT
Posts: 118
It sounds like your idle air valve needs a good cleaning. Here was my thread from a while back.

http://www.defendersource.com/forum/showthread.php?t=9375

In regards to the power loss & stall, I had the same problem and fixed it by installing the amplifier module relocation kit and replacing the fuel pump relay. I've recently installed a mallory distributor so I have the amplier relocation kit for sale in the classifieds section, if you're interested.


Reply With Quote
  #3  
Old October 11th, 2006, 03:04 PM
cellulararrest's Avatar
cellulararrest
Status: Offline
Chris Snyder
1994 D90 #614 | '07 L322 SC
Member
 
Join Date: Feb 2006
Location: Newburyport, MA
Posts: 1,544
Thanks for your quick reply!

Quote:
It sounds like your idle air valve needs a good cleaning.
Where is the idle air valve? I'm sure I could poke around under there and find it, but do you have a photo or anything?



Quote:
In regards to the power loss & stall, I had the same problem and fixed it by installing the amplifier module relocation kit and replacing the fuel pump relay. I've recently installed a mallory distributor so I have the amplier relocation kit for sale in the classifieds section, if you're interested.
Amplified module relocation kit? What purpose does this serve? Do it get wet? It has happened to me in both wet and dry conditions, so I'm not sure what good keeping it from getting wet would do. I'd be interested to hear more.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old October 11th, 2006, 05:05 PM
jimngo's Avatar
jimngo
Status: Offline
Jim Ngo
1994 D90 #80
Member
 
Join Date: Aug 2006
Location: Salt Lake City, UT
Posts: 118
The idle air control valve is on the passenger side of the intake manifold and looks like this:

http://www.defendersource.com/forum/...8&postcount=19

The amplifier module was originally attached to the distributor where heat & vibration sometimes causes an early death. The module relocation kit takes the amplifier module off the distributor and on to the driver side wing next to the ignition coil. If you have an aluminum bracket next to the coil with a black 2" X 2" module and a bunch of wires on it then you have already had this installed.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
idle

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
high idle only when moving question.. wantone Defender Technical Discussions 14 November 20th, 2009 07:03 PM
High idle problem MAF ? TPS? other? MonLand Defender Technical Discussions 30 February 5th, 2007 03:33 PM
High Idle on 97 D90 ndhlp Defender Technical Discussions 3 November 26th, 2006 11:59 AM
High Idle tron Defender Technical Discussions 5 February 15th, 2006 03:33 PM
Very high idle, sorta, just appeared yesterday Hans Defender Technical Discussions 3 December 6th, 2004 08:16 PM


All times are GMT -5. The time now is 07:16 AM.


Copyright