high beam troubles - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old May 17th, 2007, 10:37 PM
oldscratchggf's Avatar
oldscratchggf
Status: Offline
nate
95 d90
Member
 
Join Date: Apr 2005
Location: california
Posts: 660
high beam troubles

When I turn on the high beams, power is cut to all the front lights. This only happens if I switch them on (push the lever forward towards the dash) not if I hold them on (pull the lever towards myself). I already replaced the switch, but that didn`t do the trick. Any ideas?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old May 18th, 2007, 12:38 PM
oldscratchggf's Avatar
oldscratchggf
Status: Offline
nate
95 d90
Member
 
Join Date: Apr 2005
Location: california
Posts: 660
bump
Reply With Quote
  #3  
Old May 19th, 2007, 04:53 PM
redrockrover's Avatar
redrockrover
Status: Offline
Russell Phillips
1994 Defender 90
Member
 
Join Date: Feb 2004
Location: South Jordan, Utah
Posts: 81
Just a quick guess I have would be the high beam switch. I would think the blinker/high beam lever in the forward position is not making a good connection. The terminals are burnt out. When you pull it back the terminals are making a good connection hence the high beams work. I had to replace my blinker/high beam lever and it is not a very hard job. It just takes a little bit of time. Hope this helps.
__________________
Russ

'94 AA Yellow
# 891
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old May 19th, 2007, 07:41 PM
ini88's Avatar
ini88
Status: Offline
Daniel Marcello
Alloy+Grit Creative Director
Member
 
Join Date: Aug 2005
Location: Queens, NY
Posts: 2,816
check the connection in the high beam switch. my low beam switch connection burned out one time. I guess it gets real hot in there and can melt the plastic part that the connection is holding. i would say take it apart and see if the connection is burned out or loose.
Reply With Quote
  #5  
Old May 19th, 2007, 07:45 PM
oldscratchggf's Avatar
oldscratchggf
Status: Offline
nate
95 d90
Member
 
Join Date: Apr 2005
Location: california
Posts: 660
Already relpaced the switch, but no luck. any other ideas?
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thule #420 high rise gutter mounts lactic For Sale - Parts 4 February 28th, 2006 11:25 AM
High altitude operation with a 3.8 EFI = CRAP? solihul Defender Technical Discussions 2 January 2nd, 2006 06:15 AM
defender soft top, high miles, trade wrangler ? cafemosaic Wanted 0 December 4th, 2005 08:50 PM
Opinion on a high milage D90 Wagon jsilverman Defender Technical Discussions 4 November 10th, 2005 10:12 AM

» Defender Registry

Rubicon

Sharmin

Bella

D110DC
Add your Defender

All times are GMT -5. The time now is 07:48 PM.


Copyright