Help needed for non starting, non fuel pumping rover - Page 2 - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #21  
Old July 26th, 2009, 04:43 PM
cgalpin's Avatar
cgalpin
Status: Offline
Charles Galpin
'94 D90 ST, '63 SeriesIIA
Site Team
 
Join Date: Jan 2004
Location: South Riding, VA
Posts: 11,625
Registry
Me too. Will be posting my own thread so as to not pollute yours. Any help appreciated.

http://www.defendersource.com/forum/...317#post175317

charles
Reply With Quote
Sponsored Links
Advertisement
 
  #22  
Old July 26th, 2009, 06:38 PM
sherpamike's Avatar
sherpamike
Status: Offline
Mike Doligalski
'95 D90 ST
Member
 
Join Date: Oct 2003
Location: Tampa, FL
Posts: 625
Registry
Well my issue was fixed by replacing the electric ignition switch. Like I said above, it was a huge pain to replace- especially since I did it late at night and outside- but that finally did solve my problem. Now... I am still not sure what caused the original switch to blow apart like it did. And I ended up having to replace the battery about a week after i replaced the switch. Ever since then I've been smooth sailing.
Reply With Quote
  #23  
Old July 26th, 2009, 09:35 PM
cgalpin's Avatar
cgalpin
Status: Offline
Charles Galpin
'94 D90 ST, '63 SeriesIIA
Site Team
 
Join Date: Jan 2004
Location: South Riding, VA
Posts: 11,625
Registry
Good to hear. I replaced my ignition switch as I was skeptical of it. It wasn't that hard to replace, but unscrewing the two little screws that hold it did take some patience. But that didn't help my issue
Reply With Quote
Sponsored Links
Advertisement
 
  #24  
Old July 28th, 2009, 11:29 AM
cdb
Status: Offline
Clark Bowen
1969 Series 2a/OM617 Bugeye 88"
Member
 
Join Date: Jun 2006
Location: Oregon, USA
Posts: 775
My starting problems turned out to be the ignition switch too.
__________________
2011 RR HSE -
1970 LR Series 2A Bugeye BenzOver
2001 GMC 2500 4wd
Reply With Quote
  #25  
Old July 28th, 2009, 11:49 AM
sherpamike's Avatar
sherpamike
Status: Offline
Mike Doligalski
'95 D90 ST
Member
 
Join Date: Oct 2003
Location: Tampa, FL
Posts: 625
Registry
Clark, I assume that means yours is running now? If so, that's great news!
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
fuel, start, starting

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
300 Tdi Egt Q?????? Buckon37s Defender Technical Discussions 37 July 11th, 2012 11:26 AM
Good Bye Ford, Hello Tata... It's done. JFD Misc. Chit-Chat 46 April 3rd, 2008 02:49 PM
Land Rover family tree D901619 Defender Technical Discussions 9 July 5th, 2007 04:34 PM
95 won't start, possible fuel priming issue? jcasteel Defender Technical Discussions 1 March 15th, 2005 09:45 AM
Oil Info XD90 Defender Technical Discussions 5 September 7th, 2004 10:07 PM


All times are GMT -5. The time now is 08:18 PM.


Copyright