HELP! Indicators, Dash, Electrical Problems - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old April 11th, 2007, 07:59 PM
minorthreat
Status: Offline
Lance
1997 LE, 1997 Black ST
Member
 
Join Date: Aug 2004
Location: Ohio
Posts: 129
HELP! Indicators, Dash, Electrical Problems

I have a couple problems. During the day, my only my right rear brake works. I believe the other one is burned out. I know I probably need to change the bulb/harness... good to go. I'm not sure if this could be, in a strange way, related to the below issue.

The other issue, when I use my left indicator with my headlights off, the entire dash illumination blinks on and off. When I turn the lights on, the left rear indicator stays on and of course does not blink when used. However, there is also no effect on the dash illumination.

Has anyone ever had this problem? I suppose I should fix the brake light first to eliminate that as a contributing factor.

Any input would be greatly appreciated.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old April 11th, 2007, 08:55 PM
JimC's Avatar
JimC
Status: Offline
Jim Cheney
NAS 110 #145
Site Team
 
Join Date: Sep 2003
Location: Stuttgart, Germany
Posts: 7,154
Registry
You can have really wierd problems relating to the tail lights and the dash lights, check out my problem from late last year:

http://www.defendersource.com/forum/...ght=bulb+short

Its not exactly the same problem, and may well not be the solution, but it is illustrative of the connection between the two systems.

In the end, I discoved that my brake light circuit fuse was blown. I replaced it, but as soon as I hit the brakes, the fuse blew again. I would start by replacing all the lights with new fresh ones. Then if that doesnt fix it, start looking at the corroded tail light connectors and harnesses. Good luck.
Reply With Quote
  #3  
Old April 11th, 2007, 09:01 PM
Stmpede's Avatar
Stmpede
Status: Offline
Andrew Najarian
'93 NAS D110 #43
Member
 
Join Date: Mar 2007
Location: Jacksonville, FL
Posts: 2,459
Quote:
Originally Posted by [color=black
junkyddog11[/color]]The culprit has been up inside the frame rail where the trailer plug is connected and will resemble a small snake that has eaten a large rodent (that is wearing a green sweater)
I love the description!

Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old April 11th, 2007, 09:19 PM
huck1974's Avatar
huck1974
Status: Offline
shane cates
94 d90
Member
 
Join Date: Feb 2007
Location: springfield mo
Posts: 890
mine is also a little screwed up like that. I have traced it down to bad trailer wiring attempt. I have also had lights working when they want only to find the connections to the back of the lights needed to be cleaned up.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
dash, electrical, problems

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Center dash electrical gremlins kellymoe Defender Technical Discussions 6 December 8th, 2009 01:37 AM
Experiencing wierd electrical problems, engine power issues? madcowdungbeetle Defender Technical Discussions 0 May 26th, 2008 10:14 PM
Rear Door Electrical problems, what first? Hammertime Defender Technical Discussions 2 August 5th, 2007 01:01 PM
Brakelights turn on dash lights - stupidest electrical problem ever JimC Defender Technical Discussions 7 October 18th, 2006 06:21 AM
reciever electrical problems yellowrover Defender Technical Discussions 7 March 17th, 2004 05:13 PM


All times are GMT -5. The time now is 05:56 AM.


Copyright