Help! Battery drains in a day - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old August 15th, 2008, 05:03 PM
clancelotta
Status: Offline
Lancelotta
Member
 
Join Date: Mar 2004
Location: United States
Posts: 7
Help! Battery drains in a day

I have a 95 D90 and am having electrical problems - in short (no pun), the battery drains in a day or so, and does not appear to charge when driving.

I've suspected that there is a short somewhere, but cannot find it. I've taken it to Rover dealers and local shops for help - no dice. Recently I replaced the (aftermarket) radio thinking there might be a short there - this didn't fix the problem. If I connect jumper cables it starts right up.

The only other aftermarket item are driving lights, but they don't appear to be problematic.

If anyone has any input that may prove helpful I'd very much appreciate it!

Thanks
Charles
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old August 15th, 2008, 07:56 PM
hutch's Avatar
hutch
Status: Offline
Hutch
97 AA Yellow D90 ST
Member
 
Join Date: Apr 2006
Location: Tampa Bay, Florida
Posts: 173
Registry
On my 95 I once tried to strip away the old wiring of some lights and I must have missed a bare wire. It was in contact, just in front of the dash cluster, with the body. It would slowly eat away at the battery. I would check that lighting - namely the wires leading to it. Have you smashed any of the wiring recently accidentally? You may have just rubbed the coating down to the bare wire.
Reply With Quote
  #3  
Old August 16th, 2008, 12:49 AM
cgalpin's Avatar
cgalpin
Status: Offline
Charles Galpin
'94 D90 ST, '63 SeriesIIA
Site Team
 
Join Date: Jan 2004
Location: South Riding, VA
Posts: 11,625
Registry
Charles, I'd get your battery tested to see if it can hold a charge, and then test your alternator. One way to test the alternator without removing it and taking it to the parts store is to disconnect the negative terminal from the battery while the truck is running. If it keeps running your alternator is likely fine.

hth
charles
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old August 16th, 2008, 08:40 AM
Capt Milks's Avatar
Capt Milks
Status: Offline
Mike
Defender V-8, Defender 2.25
Member
 
Join Date: Oct 2004
Location: United States
Posts: 1,801
Also check your grounds. On the battery and at the body connections. If they are narlie clean them up to make sure you have a good contact.
Reply With Quote
  #5  
Old August 16th, 2008, 01:21 PM
madcowdungbeetle
Status: Offline
Carter
1994 D90 on 37s supreme balla style
Member
 
Join Date: Jan 2006
Location: Charlotte, NC
Posts: 1,359
Registry
Check your battery cables. I experienced similar symptoms and it turned out up into the sheath of the cable had deteriorated. Replaced the cable, and all was well again.
__________________
<
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
>
Reply With Quote
  #6  
Old August 16th, 2008, 10:28 PM
clancelotta
Status: Offline
Lancelotta
Member
 
Join Date: Mar 2004
Location: United States
Posts: 7
Where should I look?

Quote:
Originally Posted by madcowdungbeetle
Check your battery cables. I experienced similar symptoms and it turned out up into the sheath of the cable had deteriorated. Replaced the cable, and all was well again.
The immediately visible cables look ok, but I haven't tracked them beyond the battery compartment.
(I have killed off several batteries, so I'm sure its not the core).

Thanks!
Charles
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
battery, drain

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Best way across the US Mike Hippert Defender Technical Discussions 173 April 29th, 2010 04:56 PM
WNWPP D90 Dual Battery Tray! DJ Menasco Defender Technical Discussions 15 July 29th, 2009 12:00 AM
Dead Battery! And Random Stuff Mike Hippert Misc. Chit-Chat 24 May 31st, 2004 08:49 PM
GWNF Day Trippin' loykd Trips, Trails and Events 19 May 20th, 2004 01:40 PM
Sealed battery? OCD90 Defender Technical Discussions 4 December 22nd, 2003 01:43 PM


All times are GMT -5. The time now is 01:46 AM.


Copyright