Headlamp (and other) Problems - Page 2 - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #21  
Old December 15th, 2013, 10:15 AM
Howski's Avatar
Howski
Status: Offline
Kevin
2002 Land Rover Discovery II
Member
 
Join Date: Jul 2012
Location: Greenville, SC
Posts: 657
Registry
As I thought, no difference with the 3rd brake light unhooked. Atleast I can eliminate that issue

Turn signals are also now not working properly. There's a clicking noise coming from the fuse block area in the cabin when I turn them on. The trailer light is also illuminated when I turn them on. Not sure if this would be related to my other issues or maybe the hazard switch. When the hazard light is on the hazard lights blink incredibly fast

------ Follow up post added December 15th, 2013 10:17 AM ------

Quote:
Originally Posted by leastonce View Post
All vehicle power systems are related to the ignition switch with the exception of marker lights, interior lights and anything else that works with the key out ... Might include brake lights.
These accessories would also utilize the wiring from the ignition switch to the starter, correct? That area of the wiring is a bit of a hack job
__________________
My other car's a Land Rover
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
lamp, problems

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 06:18 AM.


Copyright