head light issues - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old April 27th, 2013, 01:23 PM
Skeena river rover's Avatar
Skeena river rover
Status: Offline
jeroen
1997 300 TDI 110
Member
 
Join Date: Sep 2011
Location: Terrace BC Canada
Posts: 358
head light issues

I have a small problem. since a couple day's my head lights work only some times! if i flick on the lights they work, or not. The next time i flick them on they don't! When they are on they stay on. But when they don;t work they will not work. Maybe a bad ground wire?
Anybody any thought's on the problem?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old April 27th, 2013, 01:37 PM
Skeena river rover's Avatar
Skeena river rover
Status: Offline
jeroen
1997 300 TDI 110
Member
 
Join Date: Sep 2011
Location: Terrace BC Canada
Posts: 358
Thanks Jeff,

I will look into it!
Reply With Quote
  #3  
Old April 27th, 2013, 02:22 PM
Broncoduecer's Avatar
Broncoduecer
Status: Offline
peter
D90
Member
 
Join Date: Jan 2011
Location: NV
Posts: 1,434
I had my switch go out on me on the way home one night. Only the brights would work! I got flashed a lot on the way home. I have also put in a painless headlight harness with upgraded hella headlights. Easy job and they are heaps better than stock.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old April 27th, 2013, 03:21 PM
Ignotus
Status: Offline
gene
1960 109, w/200TDI
Member
 
Join Date: Sep 2012
Location: 3rd rock from the Sun
Posts: 401
lites

I am not that familiar with the Defender wiring but on my Series I had a loose connector by the radiator support panel. I'd hit a bump and the headlights would go out, hit the next bump and they would go back on. The wire was in the connecter just not making fulltime contact.
When your headlights are not working start at the headlights and start jiggling wires or use a test light probe and see where the power stops. If it's going to the switch from the fuse but not going out, it's a problem with the switch.
I've been succesfull with cleaning switches by cleaning with electric motor cleaner, comes in a spray can, CRC brand. Some switches can be taken apart and the contacts cleaned with a jewlers file or fine sand paper.

gene
Reply With Quote
  #5  
Old April 29th, 2013, 12:38 AM
Skeena river rover's Avatar
Skeena river rover
Status: Offline
jeroen
1997 300 TDI 110
Member
 
Join Date: Sep 2011
Location: Terrace BC Canada
Posts: 358
ok i am bit closer now. The head lights are working. BUT. the right side tail light and the right side small light above the head light will not work. I checked fuses, lamps etc it is all good! but they don't work. I also lost my dash lights ( light from the guages). Any thoughts????
Reply With Quote
  #6  
Old April 29th, 2013, 01:33 AM
Skeena river rover's Avatar
Skeena river rover
Status: Offline
jeroen
1997 300 TDI 110
Member
 
Join Date: Sep 2011
Location: Terrace BC Canada
Posts: 358
Nope i did not replaced the switch. I will take a view days for it to be here. But now i lost my dash lights i thought it might be a fuse!. But if all these problems are related to a bad switch i am happy because it will be a easy fix
Reply With Quote
  #7  
Old April 29th, 2013, 01:40 AM
Mybluett's Avatar
Mybluett
Status: Online
Defenders Northwest
110SW
D-90 Source Vendor
 
Join Date: Dec 2011
Location: Gig Harbor, WA
Posts: 2,016
Registry
Quote:
Originally Posted by Skeena river rover View Post
Nope i did not replaced the switch. I will take a view days for it to be here. But now i lost my dash lights i thought it might be a fuse!. But if all these problems are related to a bad switch i am happy because it will be a easy fix
check the ground, and hit the connector with some cleaner while you wait for a new switch.
Reply With Quote
  #8  
Old April 29th, 2013, 10:54 AM
hillstrubl's Avatar
hillstrubl
Status: Offline
Danny
2005 Disco 3
Member
 
Join Date: Mar 2010
Location: Philly, USA
Posts: 1,596
Quote:
Originally Posted by Mybluett View Post
check the ground, and hit the connector with some cleaner while you wait for a new switch.
x3 (4?) its likely the switch. Order one of these while you're at it to prevent it from happening again -> http://www.rallylights.com/detail.aspx?ID=1247 via http://www.defendersource.com/forum/...dlight+harness
__________________
~2005 Disco 3 "Moneypenny"
~2008 GTI TSI
~If you can read this, thank a teacher. If you are reading this in English, thank a Veteran.
Reply With Quote
  #9  
Old April 30th, 2013, 01:19 AM
Skeena river rover's Avatar
Skeena river rover
Status: Offline
jeroen
1997 300 TDI 110
Member
 
Join Date: Sep 2011
Location: Terrace BC Canada
Posts: 358
thanks guys.

ps where can i find the ground wire? bulkhead?
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash, Running & Head light PROBLEM ! Weldon Defender Technical Discussions 5 November 9th, 2005 02:04 PM
Some notes on head gasket swap issues Hans Misc. Chit-Chat 0 January 17th, 2005 06:40 PM
light/ windshield issues jperakis Defender Technical Discussions 2 December 12th, 2004 02:11 PM
Head Lamp issues Clarson1359 Defender Technical Discussions 1 September 28th, 2004 04:25 PM
Head Light Harness Upgrade $30 dnewman9 For Sale - Parts 0 August 1st, 2004 11:18 AM


All times are GMT -5. The time now is 03:44 PM.


Copyright