Hazard/Directional issue (NAS D90) - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old August 30th, 2010, 08:02 PM
jaygoss's Avatar
jaygoss
Status: Offline
Jay Goss
'60 Series II Station Wagon
Member
 
Join Date: Oct 2009
Location: Asheville, NC
Posts: 363
Hazard/Directional issue (NAS D90)

Hey folks,

I have an issue where my hazard flasher doesn't work. When the ignition is off and the button is pressed nothing happens. When the ignition is on, nothing happens..but when the directionals are flashing (one side or the other), depressing the hazard button shuts them off until it is released, then the directional starts flashing again. I thought I had a bad switch, so I ordered a new one from Rovers North. Funny thing is, when I replaced it not only did the hazard flasher not work, but the directionals were non-functional. I replaced the new switch with the original and now the directionals work but I'm back to square one with a non-working hazard flasher system. I'm guessing I got a bad switch from RN, as it should have at least produced the same symptoms as the old switch did if there was a wiring or relay issue elsewhere. Does this issue ring a bell with anyone? Any ideas as to where I can look next- relay perhaps? If so, where is it? Didn't see anything readily apparent behind the hazard/clock/cig lighter panel.
__________________
1960 Series II 88" SW
1994 D90 ST Arles Blue (sold)
1963 SIIa SWB (sold)
1971 SIIa SWB (sold)
2000 Disco SII (sold)
1995 RR Classic SWB TWR edition (sold)
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old September 4th, 2010, 03:30 AM
jaygoss's Avatar
jaygoss
Status: Offline
Jay Goss
'60 Series II Station Wagon
Member
 
Join Date: Oct 2009
Location: Asheville, NC
Posts: 363
bump
__________________
1960 Series II 88" SW
1994 D90 ST Arles Blue (sold)
1963 SIIa SWB (sold)
1971 SIIa SWB (sold)
2000 Disco SII (sold)
1995 RR Classic SWB TWR edition (sold)
Reply With Quote
  #3  
Old September 4th, 2010, 04:29 AM
PaulMc's Avatar
PaulMc
Status: Offline
Paul McConnell
1989 110 2.5 Turbo-Diesel
Member
 
Join Date: Aug 2008
Location: Kent, UK
Posts: 90
Registry
Quote:
Originally Posted by jaygoss View Post
Hey folks,

I have an issue where my hazard flasher doesn't work. When the ignition is off and the button is pressed nothing happens. When the ignition is on, nothing happens..but when the directionals are flashing (one side or the other), depressing the hazard button shuts them off until it is released, then the directional starts flashing again. I thought I had a bad switch, so I ordered a new one from Rovers North. Funny thing is, when I replaced it not only did the hazard flasher not work, but the directionals were non-functional. I replaced the new switch with the original and now the directionals work but I'm back to square one with a non-working hazard flasher system. I'm guessing I got a bad switch from RN, as it should have at least produced the same symptoms as the old switch did if there was a wiring or relay issue elsewhere. Does this issue ring a bell with anyone? Any ideas as to where I can look next- relay perhaps? If so, where is it? Didn't see anything readily apparent behind the hazard/clock/cig lighter panel.

I'm not sure why you had a change of symptoms with the new switch

The problem with the Hazard Flashers sounds as though you have no power on the permanent live Purple wire on Pin 2 of the switch connector.

See my post, in this thread -

http://www.defendersource.com/forum/...2&postcount=38


In which, I've posted the wiring diagram and switch connector for the Hazards and indicators.


If there is power on the Purple wire - then I would be looking at the electronic flasher unit next, as the possible cause of the problem.


.
__________________
Paul.
1989 Arles Blue 2.5TD 110 Hardtop

1999 Epsom Green Discovery II 4.0 V8i 'XS'

.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
90, d90, nas

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
'97 Nas D90 Sw Le #008/300 Classic Rover For Sale - Vehicles 19 November 28th, 2013 08:53 AM
1995 D90 NAS Frame, 3.9L V8 & Radiator for sale Barnett Childress For Sale - Parts 10 June 22nd, 2005 07:38 PM
NAS spec D90 tune resistor help required UKlandyandy Defender Technical Discussions 8 May 7th, 2005 07:05 AM
uk windshield frame vs. nas d90? steved90 Defender Technical Discussions 3 April 5th, 2005 09:07 AM
Non NAS D90 Hardtop lrnasd90 Wanted 1 April 24th, 2004 12:07 AM


All times are GMT -5. The time now is 08:32 AM.


Copyright