hard start / rough idle after, mostly during wet condition - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old August 20th, 2012, 10:58 AM
corrumpu
Status: Offline
chris b
1995/RRC SWB
Member
 
Join Date: Nov 2009
Location: fort walton beach, florida, usa
Posts: 191
Registry
hard start / rough idle after, mostly during wet condition

So i have a 3.9L (it's technically in a RRC SWB 95, but being it's the same as the defender engine.. figured you guys could shed some light)

It's a hard start occasionally. Usually after it sits a few days (like at the airport). It's my daily driver and has been great but recently it's becoming more cantankerous.

It starts hard after sitting or during wet weather. After it does start it's a rough idle which need a steady foot but it gets over this after 20+ seconds of idle and then it seems to get over it. Runs great the rest of the time. Couple this issue with a drain somewere on my battery and my daily driver is getting harder and harder to keep using daily!

Any thoughts or directions? I am not a mechanic, but usually do my own work after much googling, forum searching and RAVE. This issue seems to require more debugging than my internet searches bring up. Any help is appreciated.

--chris
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old August 20th, 2012, 11:06 AM
down_shift's Avatar
down_shift
Status: Offline
Russell
94' D90 ST & 06' LR3
Member
 
Join Date: Sep 2011
Location: Leesburg, VA
Posts: 4,118
Registry
Sounds like a wet dizzy. A quick test is to take the distributor cap off, spray with CRC 5-56 (or similar), and see if that solves your issue. If so, purchase a new distributer rotor and cap.
Reply With Quote
  #3  
Old August 20th, 2012, 11:21 AM
o2batsea's Avatar
o2batsea
Status: Offline
Bill Adams
66 109 sw 94 lwb
Member
 
Join Date: Jul 2009
Location: kensington md
Posts: 6,503
Registry
Check the vacuum hoses around the intake manifold. Your symptoms are classic vacuum leak. The hoses may look good but have a crack underneath or in an area that's hard to see. The major one that fails is the one for the cruise control vacuum system. If your cruise control isn't working that's usually why and it will give the engine fits.
__________________
Bill Adams

1966 109 5 door wagon 300Tdi "spermaceti fueled"
1994 RRC LeWiB "ruining the air behind me"
1968 2A 88

All my troubles are Rover
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
idle, start

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting / Rough Idle Problems 1985 V8 MeanGreen Defender Technical Discussions 16 October 25th, 2011 05:33 PM
Occasional Hard To Start and Now The Engine Spontaneously Dies artpeck Defender Technical Discussions 3 June 23rd, 2009 09:49 PM
Rough idle, stumbling, dying.... revtor Defender Technical Discussions 9 January 10th, 2008 04:28 PM
Hard Top for sale Mark Cama For Sale - Parts 0 August 31st, 2005 09:19 AM
Ignition Relocation = No Start...Help JRowe Defender Technical Discussions 5 March 8th, 2004 12:45 PM

» Defender Registry

Yamelo

Ren Ching

Pumkin

natas
Add your Defender

All times are GMT -5. The time now is 11:08 AM.


Copyright