Glow Plugs stopped working - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old March 29th, 2015, 02:16 PM
defenderholty's Avatar
defenderholty
Status: Offline
Russell
1985 LR Ninety 200tdi
Member
 
Join Date: Jul 2013
Location: Cartersville, GA
Posts: 490
Glow Plugs stopped working

I have an 85 LR Ninety 2.5NA. I bought it around 2 years ago. It has had a a few quirks and rusty problems, nothing I haven't been able to figure out. Now the glow plugs stopped working. When I turn the key to the position where the glow plugs are supposed to come on they don't.

It's still a little cool here to crank it without them. I looked for a fuse, but I didn't find one that was for the glow plugs. Any one? I guess I'll start with chasing wires.

-I looked a bit through the forum and didn't find anything specifically mentioning my problem.

thanks
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old March 29th, 2015, 03:04 PM
rdavisinva's Avatar
rdavisinva
Status: Offline
Robert Davis
N/A
Member
 
Join Date: Oct 2004
Location: USA
Posts: 6,791
Sounds like your relay went out.
I have heavy duty ones available that are simple to wire if that helps.
__________________
RDavisinVA

Uncle "Richard" Douglas has a Land Rover with big wheels that never gets stuck... until he breaks something so it won't go. Uncle Douglas always breaks something. - Anna Crowther at the Conclave 2012 (AKA Carburetor Neck)

"What's with this death wobble, Uncle Douglas, I can't keep it in 1 lane?"
UD: "Just Power through it man!"
Reply With Quote
  #3  
Old March 29th, 2015, 03:27 PM
defenderholty's Avatar
defenderholty
Status: Offline
Russell
1985 LR Ninety 200tdi
Member
 
Join Date: Jul 2013
Location: Cartersville, GA
Posts: 490
Sounds like a plan. Where is the relay in my truck?
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old March 29th, 2015, 03:53 PM
roverman2010's Avatar
roverman2010
Status: Online
John
1985 LR 90 200Tdi
Member
 
Join Date: Sep 2011
Location: Galveston Island, NearTexas
Posts: 2,327
Registry
If your wiring hasn,t been buggered about the glows are wired straight to the back of the ign switch. Remove the big brown wire with the red stripe from the first glow plug (yellow/black wire) and check for voltage when you turn the key just before the engine turns over.

Could be the ign switch is buggered or wire could have come off.

There no fuses or relays. Good luck in your quest
__________________
Edward Teach is the Blackbeard, and is a member of the Birmabright Brotherhood.

Still looking for that place where I can carry a paddle and get asked what's that.

JnK Services
FC101 GS FFR
57 LR 88" SXF 858
85 LR90
95 D1 Tdi
05 D3 HSE
97 XK8 BRG FHC For Sale
Reply With Quote
  #5  
Old March 29th, 2015, 04:21 PM
defenderholty's Avatar
defenderholty
Status: Offline
Russell
1985 LR Ninety 200tdi
Member
 
Join Date: Jul 2013
Location: Cartersville, GA
Posts: 490
Thanks,

I'll give it a look.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
top

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Front blinkers stopped working meow Defender Technical Discussions 8 September 16th, 2013 08:22 AM
Headlights stopped working JTull Defender Technical Discussions 17 November 29th, 2012 06:26 PM
AC stopped working. TxEddie1111 Defender Technical Discussions 5 September 23rd, 2010 03:27 PM
Indicators stopped working ... leastonce Defender Technical Discussions 1 November 2nd, 2009 10:25 AM
wipers stopped working MontanaD90 Defender Technical Discussions 1 February 25th, 2008 01:27 PM


All times are GMT -5. The time now is 02:22 PM.


Copyright