Glow Plug Issues- 300 Tdi - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old July 9th, 2009, 11:01 AM
Mark McDonough's Avatar
Mark McDonough
Status: Offline
Mark McDonough
66' IIa, 95 D 90 300 Tdi, 94,98 D1
Member
 
Join Date: Mar 2004
Location: Up Country, NH USA
Posts: 179
Glow Plug Issues- 300 Tdi

Hey Guys,

Anyone ever run into a situation where the glow plugs have hung or partially seized up in the bores of the cyl. head? I have #1 and #2 (from the front of the motor) that were real nasty coming out. #3 was fine and #4 wasn’t bad either but never experienced this before. I used anti-seize on the threads last install a couple years ago and was just checking things recently and never have encountered this issue before. Once I did get the glows out, I did notice that these two bores were pretty carboned up vs. what I've usually seen.

Any input on this one?

Mark
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old July 9th, 2009, 12:38 PM
JFD's Avatar
JFD
Status: Offline
Julien Dalbin
05 Tdi 90
Member
 
Join Date: Mar 2005
Location: Dominican Republic
Posts: 1,888
Why did you took them out ?
__________________
" Eventually everything connects - people, ideas, objects. The quality of the connections is the key to quality per se. "
- Charles Eames
Reply With Quote
  #3  
Old July 9th, 2009, 02:33 PM
Mark McDonough's Avatar
Mark McDonough
Status: Offline
Mark McDonough
66' IIa, 95 D 90 300 Tdi, 94,98 D1
Member
 
Join Date: Mar 2004
Location: Up Country, NH USA
Posts: 179
Glows

Routine maintainence. After many years of running diesels, I've found that checking the glows every couple of years even if things are running OK is good practice. Many of the contemporary manaufactures use inferior materials. The side effect of this on occasion is the glows swell or worse, break off. This makes for nasty maintainence and operating conditions. So all routine but this time I think I caught something just startingto happen. Right now what I dont know is just what, so thats why the post.

Any help would be appreciated
Thanks
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
300 tdi, tdi

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
300 TDI needs new glow plugs. Bosch or original Beru? sundogcwolfe Defender Technical Discussions 11 December 17th, 2009 10:36 PM
1995 SW 300 Tdi neo812 For Sale - Vehicles 6 July 31st, 2005 04:55 PM
1995 Land Rover NAS Defender 90 ST (300 Tdi) MDS For Sale - Vehicles 7 March 4th, 2005 08:55 PM
LR Glow Plug relay temp? dmarchand Defender Technical Discussions 0 June 9th, 2004 01:42 PM


All times are GMT -5. The time now is 02:31 AM.


Copyright