Gauges and Start Up Issue - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old April 13th, 2012, 11:21 AM
Defender_90
Status: Offline
Kevin Doonan
1999 RR HSE
Member
 
Join Date: Jan 2012
Location: Stamford, CT
Posts: 38
Gauges and Start Up Issue

I have a 94 D-90 that just hit 100k in miles. But just as I hit 100k, the speedo stopped working, almost like it got seized at before it roleld over to 100k. I looked into getting a new speedo, but that 600 bucks i dont have right now, any suggestions?

It is also have a squeeling sound when I start the car, anyone have any idea why it is doing this?

Thanks for any help in advance.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old April 13th, 2012, 11:32 AM
wcampbel@nas.edu's Avatar
wcampbel@nas.edu
Status: Offline
Bill Campbell
1994 D-90 ST
Member
 
Join Date: Jan 2005
Location: Arlington, VA
Posts: 727
Quote:
Originally Posted by Defender_90 View Post
I have a 94 D-90 that just hit 100k in miles. But just as I hit 100k, the speedo stopped working, almost like it got seized at before it roleld over to 100k. I looked into getting a new speedo, but that 600 bucks i dont have right now, any suggestions?

It is also have a squeeling sound when I start the car, anyone have any idea why it is doing this?

Thanks for any help in advance.
The speedo is a typical problem. It takes some effort, but here is how you fix it. www.siegecraft.us/speedo.htm.

Squeeling is probably a loose or loose and dirty belt. Check them to make sure you aren't dripping fluid on them and then tighten them up.
Reply With Quote
  #3  
Old April 13th, 2012, 12:06 PM
Defender_90
Status: Offline
Kevin Doonan
1999 RR HSE
Member
 
Join Date: Jan 2012
Location: Stamford, CT
Posts: 38
Thanks so much for the link, seems like a good little project for tomorrow.

I will look into the belts, most likely some fluid is dripping.

Thanks again.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
start

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with D90 no start jumping jellyfish Defender Technical Discussions 8 August 23rd, 2009 07:21 PM
No start loykd Defender Technical Discussions 25 September 9th, 2006 10:59 AM


All times are GMT -5. The time now is 04:01 PM.


Copyright