fuel pump and relays? - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old September 11th, 2006, 01:16 PM
steved90
Status: Offline
steven melnyk
Member
 
Join Date: Aug 2004
Location: racine, wi. USA
Posts: 318
fuel pump and relays?

hi guys ,still won't start, got stuck with the rig this weekend and finally got it home, changed the realys out, still can't hear the fuel pump go on? and my wipers and break lights don't work. what should i be looking at to get this thing running? i feel like i have tried and looked at eveything, let me know if any of you have any ideas what i should check next?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old September 11th, 2006, 02:01 PM
Neil McCauley's Avatar
Neil McCauley
Status: Offline
Neil McCauley
94 ST, 97 ST, 93 110
Member
 
Join Date: Aug 2006
Location: Los Angeles
Posts: 2,366
Check your battery connection and ground straps. My dad's 90 had a stalling problem, turned out he didn't tighten the battery connection.
Reply With Quote
  #3  
Old September 11th, 2006, 02:04 PM
steved90
Status: Offline
steven melnyk
Member
 
Join Date: Aug 2004
Location: racine, wi. USA
Posts: 318
the battery connection is tight, still not starting!
boy this is frustrating
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old September 11th, 2006, 02:07 PM
btate
Status: Offline
Bryan Tate
d90
Member
 
Join Date: Aug 2004
Location: Wilmington, NC
Posts: 479
you said you checked the large fuses in the engine compartment?
Reply With Quote
  #5  
Old September 11th, 2006, 02:10 PM
steved90
Status: Offline
steven melnyk
Member
 
Join Date: Aug 2004
Location: racine, wi. USA
Posts: 318
yup they are all good?
any other ideas??
Reply With Quote
  #6  
Old September 11th, 2006, 03:57 PM
btate
Status: Offline
Bryan Tate
d90
Member
 
Join Date: Aug 2004
Location: Wilmington, NC
Posts: 479
I am not an expert by any means, just trying to help here....but it seems like it would have to be a fuse or relay for several things to kick out like that. If I had a schematic close by I would check to see if there is a common fuse/relay for these items and start there. Are you sure you didn't short out the new relays? With that many things going out at once, it doesn't sound like a "part failure" (fuel pump wouldn't cause all these problems)
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
fuel, relay

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
YANST (Yet Another No Start Thread) - fuel pump circuit issues cgalpin Defender Technical Discussions 25 August 2nd, 2009 11:23 PM
Diagnosing Fuel Pump Issues hutch Defender Technical Discussions 40 May 21st, 2009 09:04 PM
Engine Dies: Fuel Pump & ECU Relays? jimngo Defender Technical Discussions 4 October 15th, 2006 01:25 PM
Fuel pump relay 95 D90SW alaskajgg Defender Technical Discussions 32 September 18th, 2006 10:26 AM
95 won't start, possible fuel priming issue? jcasteel Defender Technical Discussions 1 March 15th, 2005 09:45 AM


All times are GMT -5. The time now is 08:41 PM.


Copyright