Fuel pump and fuel gauge relationship question - troubleshoting... - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old September 17th, 2006, 04:56 PM
arbik
Status: Offline
Arbi Karapetian
1995 D-90 SW #163/500
Member
 
Join Date: Jan 2005
Location: La Crescenta, CA, USA
Posts: 175
Fuel pump and fuel gauge relationship question - troubleshoting...

Hi guys,

So I'm still trouble shooting my D90.
I've eliminated the relays and the fuese as the problem. I'll be taking off the line from the filter to make sure of this. But I'm suspecting the pump to have failed. The truck has about 125K on it.

my fuel gauge works though, so can I assume from this, that since the sender/pump assy is a single unit, that there is electricity going to the assembly?

thanks,

-arbi
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old September 19th, 2006, 02:31 PM
arbik
Status: Offline
Arbi Karapetian
1995 D-90 SW #163/500
Member
 
Join Date: Jan 2005
Location: La Crescenta, CA, USA
Posts: 175
For future reference...

Ok,

so since I found the answer to this, I'll answer it in case someone in the future does a search for the same question.

The answer is, you know at least for a fact that the connector is attached to the fuel pump assy.
the wires are separate though, but they do come in the same wiring harness, so chances are, if you can see fuel level, then your fuel pump is getting electricity, if you have juice at the relays.

-arbi
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
fuel

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fried fuel pump mattdh Defender Technical Discussions 2 July 13th, 2012 02:55 PM
300 Tdi Egt Q?????? Buckon37s Defender Technical Discussions 37 July 11th, 2012 11:26 AM
Diagnosing Fuel Pump Issues hutch Defender Technical Discussions 40 May 21st, 2009 09:04 PM
Fuel Pump Fuse Blows all the Time now! thug1313 Defender Technical Discussions 9 March 2nd, 2006 07:55 PM
Rats! Now my D90 won't start. No power to fuel pump jcasteel Defender Technical Discussions 8 March 15th, 2005 09:42 AM


All times are GMT -5. The time now is 10:38 PM.


Copyright