fuel injectors not working - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Join the Defender Source Community Today

Thread Tools
Old May 24th, 2007, 04:54 PM
matt's Avatar
Status: Offline
Matt White
1994 Defender 90
Join Date: Mar 2007
Location: DeLand Florida U.S.
Posts: 2
fuel injectors not working

I am having a similar problem as Jason in the last thread. My D-90 has had kind of a domino effect the last few days. It started out with a fuel pump that went out. I replaced it, drove it for about an hour, then went to start it back up and it would not start. It turns over, but doesn't start. My mechanic and I are stumped. All relays work, all fuses are in tact, but now the fuel injectors will not turn on, and it has an irregular spark pattern from the distributor. I pulled the ECM, and replaced a burned out mosfet circuit. Still nothing. Can anyone offer any more suggestions, as I am all out of ideas?

Reply With Quote
Old May 24th, 2007, 05:28 PM
Davis's Avatar
Status: Offline
Chris Davis
94 D90, 88 RRC
Join Date: Nov 2003
Location: Colorado
Posts: 2,104
Check the wire from the coil that triggers the injectors...make sure the injectors are getting the signal. Maybe.
Reply With Quote

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
fried fuel pump mattdh Defender Technical Discussions 2 July 13th, 2012 01:55 PM
300 Tdi Egt Q?????? Buckon37s Defender Technical Discussions 37 July 11th, 2012 10:26 AM
Diagnosing Fuel Pump Issues hutch Defender Technical Discussions 40 May 21st, 2009 08:04 PM
Fuel Pump Fuse Blows all the Time now! thug1313 Defender Technical Discussions 9 March 2nd, 2006 07:55 PM
95 won't start, possible fuel priming issue? jcasteel Defender Technical Discussions 1 March 15th, 2005 09:45 AM

All times are GMT -5. The time now is 08:31 PM.