Few more questions.. - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old August 3rd, 2014, 07:58 PM
Kdawg97m3
Status: Offline
Kristian
1994 D90
Member
 
Join Date: Oct 2010
Location: Dawgs, GA
Posts: 110
Few more questions..

So I have a turn signal issue....for the first time today the signal would not operate...then came stop and fooled around with the stalk and it seems to "work" then stop. So I assume the stalk is bad. But every works fine...I notice now the trailer light pops on once when the signals are initiated, is that correct?



Also my trailer light comes on with my hazard amd no turn signal light?? is that supposed to happen?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old August 3rd, 2014, 08:12 PM
rankar's Avatar
rankar
Status: Offline
Randy
97 SW #2236 (Maggie)
Member
 
Join Date: Aug 2013
Location: CT
Posts: 1,117
Registry
Yes because the trailer connector is energized.

Do your hazard lights flash?
Reply With Quote
  #3  
Old August 3rd, 2014, 09:41 PM
Reese_D90's Avatar
Reese_D90
Status: Offline
Reese
97 D90 ST and 93 D110
Member
 
Join Date: Oct 2009
Location: Dallas, Texas, USA
Posts: 1,260
Registry
May not be the issue but hit the hazards a couple of times. If they are not completely off and reseated (i.e. - its half pushed in) it will keep blinkers from working.
__________________
NAS 1993 D110 CDN #11/25
1997 D90 ST #1953
2006 Range Rover
1997 D90 SW #701 (sold)
1995 D90 ST (sold)
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old August 3rd, 2014, 09:56 PM
Kdawg97m3
Status: Offline
Kristian
1994 D90
Member
 
Join Date: Oct 2010
Location: Dawgs, GA
Posts: 110
Quote:
Originally Posted by Reese_D90 View Post
May not be the issue but hit the hazards a couple of times. If they are not completely off and reseated (i.e. - its half pushed in) it will keep blinkers from working.

I think that is it,,,thanks
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A few moron questions about interior trim panel removal. rustydefender Defender Technical Discussions 17 March 23rd, 2016 05:12 PM
A few mishmash questions paulb Misc. Chit-Chat 1 September 22nd, 2011 12:03 PM
A few electrical questions - '92 tdi 16kpsi Defender Technical Discussions 1 September 21st, 2010 02:36 PM
Few more Parts woldd90 For Sale - Parts 7 February 11th, 2010 03:53 PM
few questions on fitting 300Tdi to NAS d90 Gkase Defender Technical Discussions 11 June 13th, 2006 03:17 PM


All times are GMT -5. The time now is 11:29 PM.


Copyright