Experiencing wierd electrical problems, engine power issues? - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old May 26th, 2008, 10:14 PM
madcowdungbeetle
Status: Offline
Carter
1994 D90 on 37s supreme balla style
Member
 
Join Date: Jan 2006
Location: Charlotte, NC
Posts: 1,359
Registry
Experiencing wierd electrical problems, engine power issues?

I've been experiencing all kinds of random electrical issues on my D90, random check engine codes, intermittant starting problems, issues with service engine light, and check engine light. Nothing major or what I would consider out of the ordinary on a truck that has been a trail rig and lived outside and with no top most of its life until the truck would not start at all.

Thought it was the battery, no go 12.5 volts across the terminals
Then a voltage drain, notta thing
Then the starter, all good here
Then the ignition, all good here when there was power

Then after a little further investigation, I pulled the sheath off of the positive terminal I found the battery cable had about 3/4 of the strands broken.

Replaced the main battery cable, truck starts every time, runs better than ever and feels like it picked up some power.

Thought I would share this in hopes that it might save someone a lot of money and time, when all it was was $15 at Autozone, and about an hour of time.... or less... depending on how clean of an install you want to do. I decided to go a step further and install a BTF metal battery box form fit for an Optima.
Attached Thumbnails
Click image for larger version

Name:	DSC07086.JPG
Views:	101
Size:	142.6 KB
ID:	13625   Click image for larger version

Name:	DSC07087.JPG
Views:	108
Size:	135.4 KB
ID:	13626  

__________________
<
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
>
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
electrical, engine, problems

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
300 Tdi Egt Q?????? Buckon37s Defender Technical Discussions 37 July 11th, 2012 11:26 AM
Rebuilding a v8 engine - how to fix liner problems robisonservice Defender Technical Discussions 10 August 19th, 2006 10:18 PM
Engine Temp issues sflash868 Defender Technical Discussions 11 May 25th, 2005 04:51 PM
Oil Info XD90 Defender Technical Discussions 5 September 7th, 2004 10:07 PM
battery/ electrical issues steve_brooks Defender Technical Discussions 1 April 23rd, 2004 04:05 PM


All times are GMT -5. The time now is 08:01 PM.


Copyright