Erratic Tachometer - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old February 4th, 2013, 05:58 PM
61rover's Avatar
61rover
Status: Offline
John Crouse
'93 NAS D110 (#8) / '61 Series II
Member
 
Join Date: Feb 2007
Location: Denver, CO
Posts: 1,116
Registry
Erratic Tachometer

So my tachometer is bouncing around and reading everything but correct. The alternator is only two monts old. Is there anything else it could be?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old February 4th, 2013, 05:59 PM
Bill Larson's Avatar
Bill Larson
Status: Offline
Bill Larson
97 D90 SW
Member
 
Join Date: Jul 2010
Location: AUS
Posts: 6,563
Bad alternator....its on its way out. IMO.
Reply With Quote
  #3  
Old February 4th, 2013, 06:05 PM
Mpigapicha's Avatar
Mpigapicha
Status: Offline
phil
1995 Defender D90
Member
 
Join Date: Sep 2009
Location: New York
Posts: 326
Quote:
Originally Posted by Bill Larson View Post
Bad alternator....its on its way out. IMO.
I'd second that. Was the alternator rebuilt?
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old February 4th, 2013, 06:53 PM
Jake1996d1's Avatar
Jake1996d1
Status: Offline
Jake
96 Disco/88 RRC
Member
 
Join Date: May 2011
Location: Ankeny IA
Posts: 451
Check the wiring too
Reply With Quote
  #5  
Old February 4th, 2013, 07:24 PM
d110pickup
Status: Offline
Mike Pado
'97 D90 ST #1153
Member
 
Join Date: Nov 2003
Location: Canton, Ga
Posts: 158
Alternator!!!

I've never had an actual tach problem, always the alternator.
Mike
Reply With Quote
  #6  
Old February 12th, 2013, 10:09 PM
61rover's Avatar
61rover
Status: Offline
John Crouse
'93 NAS D110 (#8) / '61 Series II
Member
 
Join Date: Feb 2007
Location: Denver, CO
Posts: 1,116
Registry
Loose connection at the altenator. Problem solved....
Reply With Quote
  #7  
Old February 12th, 2013, 10:50 PM
Bill Larson's Avatar
Bill Larson
Status: Offline
Bill Larson
97 D90 SW
Member
 
Join Date: Jul 2010
Location: AUS
Posts: 6,563
Good! yeah common problem.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
ac

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Something Else, Tachometer Quit Working Today BMGmotors Defender Technical Discussions 5 June 12th, 2011 05:04 AM
Tachometer AMR1912 reb78 Defender Technical Discussions 8 May 24th, 2011 04:02 PM
WTB new or like new factory Td5 tachometer ECR Wanted 2 February 3rd, 2010 07:53 AM
Dead tachometer... Weldon Defender Technical Discussions 2 January 20th, 2008 02:02 PM
Erratic Oil and Temp Sensor Jon_Winningham Defender Technical Discussions 10 March 30th, 2007 09:27 PM


All times are GMT -5. The time now is 04:54 AM.


Copyright