Engine swap well under way - Some questions - Page 2 - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #21  
Old October 5th, 2015, 09:02 AM
Kevin88RRC's Avatar
Kevin88RRC
Status: Offline
Kevin Keith
1988 RRC
Member
 
Join Date: Dec 2014
Location: Portland, Maine
Posts: 1,045
Quote:
Originally Posted by samer0214 View Post
The MAF is also connected save for a single white wire with a push on male blade connector. I couldn't find any information on it, and I couldn't find a place to connect it to. White is typically switched ignition, so is that what this wire is for, and if so, could that be part of the problem?
That wire has a black trace too right? It connects to the coil.

And I completely forgot about the coolant pipes. If you're still interested let me know... but it sounds like you've got it worked out.
Reply With Quote
Sponsored Links
Advertisement
 
  #22  
Old October 5th, 2015, 09:57 AM
samer0214's Avatar
samer0214
Status: Offline
Samer Hijazi
1997 P38 Vitesse
Member
 
Join Date: Apr 2013
Location: Irvine, CA
Posts: 390
Registry
Engine swap well under way - Some questions

Kevin, the wire is white only, no black trace, and it's not long enough to connect to the coil. It branches of the MAF harness.

There are 3 wires connected to the coil, a positive, a negative, and a switched ignition to the positive terminal. I also have spark at the coil (center terminal on the distributor), so I don't think it's an ignition issue.

As for the coolant pipes, I actually left them alone, and had a throttle cable custom made to reach, rather than having to flip the plenum.
__________________
Thank you - Samer
1997 P38 Vitesse (Red)
2003 Discovery II
Defenderless, for now!
Reply With Quote
  #23  
Old October 5th, 2015, 10:30 AM
Kevin88RRC's Avatar
Kevin88RRC
Status: Offline
Kevin Keith
1988 RRC
Member
 
Join Date: Dec 2014
Location: Portland, Maine
Posts: 1,045
You should have four wires off the coil. Defender harness may be just white without black trace and you'll have the 'chicklet' there which may explain why it won't reach.
Do a search for 'chicklet'.... here's one good post explaining it.

Quote:
Originally Posted by leastonce View Post
I can't see from the photo but it is vital that you connect the wire with that runs to the ECU to the -be side of the coil. This is the one that connect to the chicklet that's up near the MAF. Put the voltmeter on the chicklet and to ground and you should see 9v ... This should pulse with the ignition firing. This tells the ecu the engines is running and turns on the fuel pump. Without it it won't start. You can get a great spark and all that good stuff but unless that wire is connected the ECU won't pump gas.
Reply With Quote
Sponsored Links
Advertisement
 
  #24  
Old October 5th, 2015, 11:14 AM
samer0214's Avatar
samer0214
Status: Offline
Samer Hijazi
1997 P38 Vitesse
Member
 
Join Date: Apr 2013
Location: Irvine, CA
Posts: 390
Registry
Kevin: You Da Man! Genius, thank you. Connected that white wire to the Negative side of the coil, and it fired right up! Thank you, thank you.

Once again, this board proves to be invaluable. Great board, great people.
__________________
Thank you - Samer
1997 P38 Vitesse (Red)
2003 Discovery II
Defenderless, for now!
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
engine

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Carb rebuild vs FI swap vs engine swap samer0214 Defender Technical Discussions 14 July 13th, 2014 08:33 AM
97 D90 Built WAY WAY Less than low book mightymg For Sale - Vehicles 11 June 6th, 2013 08:42 PM
MB 300T Engine and some Swap bits Turbofan For Sale - Parts 2 July 24th, 2012 08:00 PM
Finished the 300TDI swap - some problems/questions jaherring Defender Technical Discussions 10 February 23rd, 2011 01:37 PM
Contura Switch 3 way and 2 way Rugbier Defender Technical Discussions 21 January 26th, 2009 11:45 PM


All times are GMT -5. The time now is 10:16 AM.


Copyright