Engine Suddenly Stops - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Join the Defender Source Community Today

Thread Tools
Old September 12th, 2011, 08:04 AM
Status: Offline
Jon Haskell
1997 NAS D90
Join Date: Sep 2011
Location: United States
Posts: 6
Engine Suddenly Stops

My NAS 1997 4.0Liter D90 with 298,000 miles, exhibited classic faulty Crank Position Sensor symptoms...engine suddenly stopping after six miles or so, but could be restarted after 10- 15 seconds. No sputtering...a quick stop.

I replaced the sensor and repaired frayed wire insulation at the connector.
It ran perfect for three days then the problem surfaced again. (The ambient temperature was cooler those days...not sure of relevancy) The problem remains sporadic and can happen regardless of terrain or speed. The last event was at idle speed others at 40-50mph.

So...what are the groups thoughts on some other things that I should look into?

thanks much....Jon

Reply With Quote
Old September 12th, 2011, 09:15 AM
djrover's Avatar
Status: Offline
Dave Johnson
'91 RRC
Join Date: Jan 2011
Location: Rochester, NY USA
Posts: 77
I am sure you checked the wiring to the fuel pump and the ground. Common place to corrode, break, etc...Or the pump itself.

Dave J.
'91 RR Classic
'01 RR 4.6 HSE - Gone!
'00 Disco 2 - Gone!
'95 Disco 5-Spd - Gone!
'92 RR County SWB - Gone!
'63 2A SWB - Gone!
Reply With Quote
Old September 12th, 2011, 09:53 AM
chris snell's Avatar
chris snell
Status: Offline
Chris Snell
87 Ex-MOD 110
Join Date: Aug 2005
Location: Kansas
Posts: 2,414
Check the wiring on the bottom of your ignition coil. Those spade connectors can sometimes work themselves loose, which will produce those symptoms.
Reply With Quote
Old September 12th, 2011, 03:44 PM
Davis's Avatar
Status: Offline
Chris Davis
94 D90, 88 RRC
Join Date: Nov 2003
Location: Colorado
Posts: 2,104
I had something similar and it turned out to be a faulty ignition switch. I would just die on the freeway, then I could not restart and then, out of nowhere, it would restart fine.
Reply With Quote

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Proble: Please Advise saber6 Defender Technical Discussions 24 November 6th, 2009 10:06 AM
service engine VS. check engine scubadanster Defender Technical Discussions 18 June 23rd, 2009 10:18 AM
Engine Stalls Suddenly When Driving Ragland Defender Technical Discussions 15 February 4th, 2006 12:30 PM
Oil Info XD90 Defender Technical Discussions 5 September 7th, 2004 09:07 PM
???still can't get the trany unbolted from the engine???? kit Defender Technical Discussions 4 October 23rd, 2003 02:20 PM

All times are GMT -5. The time now is 01:31 PM.