Engine rebuild/replace advise needed. - Page 6 - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #101  
Old April 17th, 2007, 01:46 AM
Bowtracer's Avatar
Bowtracer
Status: Offline
Peter Sherman
NAS 110
Member
 
Join Date: May 2004
Location: Old Mill Creek IL
Posts: 690
Jim did you listen to the vid????
Reply With Quote
Sponsored Links
Advertisement
 
  #102  
Old April 17th, 2007, 02:10 AM
pendy's Avatar
pendy
Status: Offline
jim pendleton
89'd90
Member
 
Join Date: Oct 2003
Location: andover, ks usa
Posts: 2,341
No. I will now.

JP

Follow-up Post:

Sounds like low oil pressure even when it is cold. Its doing camage to run it like that. Duh.... Maybe a bad cam bearing or dirty oil circuit causing low oil pressure to the top end. Pulling the pan is a good idea.

It may sound crazy but this is what I would do. Pull the pan. Look for problems. Note any.

Remove the pickup tube from the block. Use an air nozzle to pressurize the oil circuit. Look for the main leak that is causing low oil pressure to the top end. Bad main bearing. Bad Cam bearing, Bad rod bearing etc... If nothing shows up remove the rockers and pressurize to comfirm blockage to the top end. And maybe use cleaning fluids and devices to free up the oil circuit to the top end.

But my bet is an internal oil pressure leak lowering oil pressure to the top end.

JP

Try to save it.
__________________
legend in my own mind

Advice is only as good as the person applying it--
Don't make me give you bad advice!

Lemons or lemonaide, whatever your taste provides.
Reply With Quote
  #103  
Old April 17th, 2007, 03:30 AM
jaherring's Avatar
jaherring
Status: Offline
Jason Herring
94 D90 ST #1253
Member
 
Join Date: May 2004
Location: San Pedro, CA, USA
Posts: 582
I had some top end noise once - it ended up being a seized lifter. That lifter ground down the lobe on my cam to nearly round, at which point the noise got much worse and it was understandably no longer firing on that particular cylinder.

New cam/lifters fixed it right up. The cam bearings weren't showing any copper.

I have had the misfortune of experiencing nearly everything which can fail on this truck, FYI. I said *nearly*, as I'm still experiencing new and exciting disasters, such as my current maybe-cracked-block-or-slipped-liner dilema.
Reply With Quote
Sponsored Links
Advertisement
 
  #104  
Old May 15th, 2007, 09:03 PM
cgalpin's Avatar
cgalpin
Status: Offline
Charles Galpin
'94 D90 ST, '63 SeriesIIA
Site Team
 
Join Date: Jan 2004
Location: South Riding, VA
Posts: 11,625
Registry
I've already decided I don't trust this engine, and it's replacement is in the works (thanks Pendy). But I'd still like to better understand what's wrong with mine. I drilled a hole in the oil pressure sender and tapped a thread to match a oil pressure sender I bought at pep boys. I hooked it up and got the following readings:

Cold: Idles and about 30 psi, went up to about 35psi on the road.

Hot: Idles at about 20 psi (maybe 19), and ran about 30 on the road.

From what I have read here this seems pretty good, although I don't know if these gauges are reliable or need calibrated somehow. Maybe I'll get my friend Loic to try it on his truck as a reference

charles
Reply With Quote
  #105  
Old May 24th, 2007, 09:14 AM
cgalpin's Avatar
cgalpin
Status: Offline
Charles Galpin
'94 D90 ST, '63 SeriesIIA
Site Team
 
Join Date: Jan 2004
Location: South Riding, VA
Posts: 11,625
Registry
Haven't gotten to compare pressure readings with Loic as he's out of town. I suspect the engine is fine and just needs a top end rebuild, but that will be another day or left to someone else. Anyone want to buy a 3.9 long block (will include the timing cover and all)?

Just to close out this thread, the replacement is going to take place on June 2nd.

http://www.defendersource.com/forum/...3831#post93831

charles
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
ac, engine, rebuild

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
300 Tdi Egt Q?????? Buckon37s Defender Technical Discussions 37 July 11th, 2012 11:26 AM
Engine Proble: Please Advise saber6 Defender Technical Discussions 24 November 6th, 2009 10:06 AM
service engine VS. check engine scubadanster Defender Technical Discussions 18 June 23rd, 2009 11:18 AM
Turbo/Supercharger upgrade advise needed babushka99 Defender Technical Discussions 2 October 16th, 2004 08:26 PM
Oil Info XD90 Defender Technical Discussions 5 September 7th, 2004 10:07 PM


All times are GMT -5. The time now is 10:28 PM.


Copyright