Engine Noise coming through Radio? - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Join the Defender Source Community Today

Thread Tools
Old March 9th, 2008, 07:22 PM
Hammertime's Avatar
Status: Offline
Dana Hammersley
1997 Arles Blue #162
Join Date: Jan 2004
Location: Chambersburg, Pa U.S.A.
Posts: 376
Engine Noise coming through Radio?

I have engine noise comig through on the radio. Some days it is there some not but mostly there. Sometime I can turn the radio offf for a few seconds then turn it back on and the noise is gone for awhile. I have Bosch Platinum plugs in it. Man it is really irritating. Is there a surpressor or something I can put on this thing or if someone knows something else about it please let me know.

Due to the rising cost of ammo there will no longer be a warning shots!!!
Reply With Quote
Old March 9th, 2008, 08:24 PM
shawnpalmer's Avatar
Status: Offline
Shawn Palmer
1997 SW-Arles Blue
Join Date: Nov 2003
Location: Lake Lanier, Ga.
Posts: 1,122
This happened to me once. I solved the problem by pulling out the radio and finding a bad ground. A wire had been cut accidently. Hope you find the problem, it is annoying for sure.

There is a fine line between hobby and mental illness.

97 D90 SW
Reply With Quote
Old March 10th, 2008, 03:15 PM
TDI Guy's Avatar
Status: Offline
2015 LR4
D-90 Source Vendor
Join Date: Sep 2003
Location: NJ
Posts: 4,530
I got an antenna suppressor from Crutchfield... Cheap too
Legend in My Own Mind.
Reply With Quote
Old March 10th, 2008, 04:09 PM
ECR's Avatar
Status: Offline
East Coast Rover Co.
Just Defenders, nothing else.
D-90 Source Vendor
Join Date: May 2006
Location: Rockland, ME, USA
Posts: 4,601
We've sometimes had to replace alternators to cure this. Sometimes the suppressors work, sometimes they don't. Just did one and nothing cured it other than a different alternator.
Email: info@eastcoastrover.com
I do not check PMs. Call or email if you need something.

ECR is not a parts source. We are not in the mail order business.
Reply With Quote
Old March 10th, 2008, 08:42 PM
Status: Offline
A J Bussen
1997 D-90 ST
Join Date: Jan 2007
Location: St.Louis Mo USA
Posts: 33
I have had this problem off and on. I fix it by cleaning the connectors to the head unit and the amp under the seat. Always works.

A. J.
If it aint moto it's worthless.
Reply With Quote

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

engine, radio

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Proble: Please Advise saber6 Defender Technical Discussions 24 November 6th, 2009 10:06 AM
Engine noise in radio JBOD77 Defender Technical Discussions 8 May 20th, 2008 08:19 AM
engine noise. Campbell Defender Technical Discussions 31 October 3rd, 2005 09:34 AM
whistling noise from engine jstrong98 Defender Technical Discussions 2 December 14th, 2004 11:37 PM
Oil Info XD90 Defender Technical Discussions 5 September 7th, 2004 09:07 PM

All times are GMT -5. The time now is 07:56 AM.