Engine mounts - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old September 20th, 2006, 07:59 PM
D90user's Avatar
D90user
Status: Offline
steve
109/110 ambulance-55 series I
Member
 
Join Date: Oct 2004
Location: Nevada
Posts: 1,447
Engine mounts

What is the best way to tell if the engine mounts (300 tdi) are going bad? I have a funny yet annoying vibration only when under load that does not seem to be any of the normal culpirits.

also any one have any first hand experience with the QT heavy duty mounts?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old September 20th, 2006, 08:14 PM
dmarchand's Avatar
dmarchand
Status: Offline
David Marchand
'97 D90 SW Arles
Member
 
Join Date: Sep 2003
Location: New England
Posts: 2,862
Registry
Pull the bonnet and see of the engine jumps when revving excessively.

Although this kind of assumes you know how much the engine moves when the mounts are known to be good. Which is more than you might imagine.
Reply With Quote
  #3  
Old September 20th, 2006, 08:28 PM
jimmy salmon's Avatar
jimmy salmon
Status: Offline
jimmy salmon
94 D90 AA Yellow
Member
 
Join Date: Jun 2004
Location: Methuen MA USA
Posts: 1,342
put a block of wood under the sump and jack the engine, if the truck lifts its ok, if the engine pops off the mounts its the mounts
__________________
3rd low and BOOT IT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old September 20th, 2006, 09:06 PM
D90user's Avatar
D90user
Status: Offline
steve
109/110 ambulance-55 series I
Member
 
Join Date: Oct 2004
Location: Nevada
Posts: 1,447
I like that one jimmy... I'll give it a shot.
Hard to tell with the revving bit... tried that but with the diesel itls moves like hell anyway.
Reply With Quote
  #5  
Old September 20th, 2006, 09:07 PM
jimmy salmon's Avatar
jimmy salmon
Status: Offline
jimmy salmon
94 D90 AA Yellow
Member
 
Join Date: Jun 2004
Location: Methuen MA USA
Posts: 1,342
thats what i did with mine and the mounts came apart
__________________
3rd low and BOOT IT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
engine, mount

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
QT Services Diff Guards and HD Engine Mounts JohnC The Vendors Loft 1 February 16th, 2006 09:53 PM
Engine Mounts david_jackson Defender Technical Discussions 1 February 8th, 2006 06:48 PM
Installing engine mounts Doug Defender Technical Discussions 4 February 23rd, 2005 06:49 PM
90 main wiring harness & TDI engine mounts TDI Guy For Sale - Parts 5 December 13th, 2004 01:45 PM
Oil Info XD90 Defender Technical Discussions 5 September 7th, 2004 10:07 PM


All times are GMT -5. The time now is 01:46 AM.


Copyright