Engine light - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old October 2nd, 2009, 09:30 PM
floatflyer
Status: Offline
Bryan Krill
'95 D90 wagon
Member
 
Join Date: Aug 2009
Location: Sagle, Idaho
Posts: 42
Engine light

Just bought a '95 SW and drove it home 3000 miles. No significant problems, just a couple of annoying ones. First, the engine light came on and stayed on the whole trip. I tried to have it dignosed in Arizona with no luck. When the cover was off the right seat box we noticed a modular plug not was not connected. The plug is white in color and has three pins in a triangular pattern. I did not connect the plug for all the obvious reasons. Any help here would be greatly appreciated. The other nagging problem I had was a grating grinding noise that developed when I backed off the trottle in fifth gear on downgrades. My thought was a CV joint going, but not sure. Thanks in advance for any help.

Bryan
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old October 2nd, 2009, 09:37 PM
rover4x4's Avatar
rover4x4
Status: Offline
Phillip
1995 SW #487/500
Member
 
Join Date: Sep 2003
Location: The Old North State
Posts: 7,526
Registry
Quote:
Originally Posted by floatflyer
Just bought a '95 SW and drove it home 3000 miles. No significant problems, just a couple of annoying ones. First, the engine light came on and stayed on the whole trip. I tried to have it dignosed in Arizona with no luck. When the cover was off the right seat box we noticed a modular plug not was not connected. The plug is white in color and has three pins in a triangular pattern. I did not connect the plug for all the obvious reasons. Any help here would be greatly appreciated. The other nagging problem I had was a grating grinding noise that developed when I backed off the trottle in fifth gear on downgrades. My thought was a CV joint going, but not sure. Thanks in advance for any help.

Bryan
COngrats on your new Land Rover. I had the growl you mention when I put a OME suspension on my truck, rear links with spacers cured my problem temporarily. How many miles on your truck?
__________________
Poor gas mileage gets you to the best places on earth
Reply With Quote
  #3  
Old October 2nd, 2009, 10:12 PM
floatflyer
Status: Offline
Bryan Krill
'95 D90 wagon
Member
 
Join Date: Aug 2009
Location: Sagle, Idaho
Posts: 42
Thats' interesting, this truck has OME shocks and springs. Currently has 87,000 miles.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old October 2nd, 2009, 10:25 PM
woldd90's Avatar
woldd90
Status: Offline
Scott
1997 D90 ST #1444
Site Team
 
Join Date: Aug 2005
Location: Georgia
Posts: 5,329
Was it the Service Engine or the Check engine? The Red Service Engine is controlled up by mileage.

Could it be a U-joint going bad, a diff the needs a bit more 90 WT or putting Redline in the gear box?
__________________
Scott

Reply With Quote
  #5  
Old October 2nd, 2009, 10:29 PM
floatflyer
Status: Offline
Bryan Krill
'95 D90 wagon
Member
 
Join Date: Aug 2009
Location: Sagle, Idaho
Posts: 42
Check engine light comes on. The u joints were all just reolaced before sale. I'll check the diffs and the gear box oil.
Reply With Quote
  #6  
Old October 3rd, 2009, 03:48 AM
Rocketman's Avatar
Rocketman
Status: Offline
Scott Y
95 D90 SW, 2003 Disco II, 93 D110
Member
 
Join Date: Feb 2009
Location: Arizona
Posts: 163
Being a 95 it has OBD I. Do you have a LED display box under the passenger seat? It should be about the size of a pack of cigarettes. If so, there should be a number lit up that corresponds to the problem that the ECU thinks it is having. If the truck ran fine, it could have been an intermittent issue.If so, disconnecting the battery will clear the CEL.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
engine, ht

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light and code P1176 wingnut Defender Technical Discussions 5 October 7th, 2005 07:41 PM
check engine light. FREEDOM Defender Technical Discussions 14 May 31st, 2005 01:10 PM
Defender Check/Serive Engine Light - help! B-Kerr Defender Technical Discussions 8 May 9th, 2005 08:32 AM
Oil Info XD90 Defender Technical Discussions 5 September 7th, 2004 10:07 PM
Check engine light / Rough Road mhansen Defender Technical Discussions 16 June 9th, 2004 01:14 PM


All times are GMT -5. The time now is 06:11 AM.


Copyright