Electrical woes - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Join the Defender Source Community Today

Thread Tools
Old February 22nd, 2013, 05:55 PM
Status: Offline
Join Date: Sep 2012
Location: Saratoga/Syracuse NY
Posts: 208
Electrical woes

Ok guys as usual I'm having some electrical issues and I was wondering if anyone could give me advice before I bring it to a shop.

The issues are..
1. I have a drivers side low beam out, replacing the bulb didnt fix it.
2. When I apply the brakes, the "light" indicator light turns on while the pedal is depressed. The small clear running lights also turn on when I apply the brakes.
3. The turn signals both work, but only 1 side works when i turn my flashers on.
4. I have a brake light that stays on when I turn the lights on.
5. My aux lights that were connected to my highbeams dont turn on anymore.

Im out at school right now in syracuse ( most snow out of any city in the US ) and its not easy to chase down every wire in the thing. Judging by the symptoms is there anything that you guys would recommend to do first or to look at first? Im hoping I can resolve it without a large bill from a shop.


Reply With Quote
Old February 22nd, 2013, 06:04 PM
rijosho's Avatar
Status: Offline
1995 Black ST - Rhinolined edition
Research Assistant/Eagle Eyes
Join Date: Apr 2009
Location: NYC
Posts: 16,601
Check your light switch in your steering column. Then (since its cold as hell out) do a quick visual check of the wires you CAN see - like the ones running to your rear lights in your rear footwells. Check to make sure none have shorted out or corroded to the point that they're split in 2. Then get a test light and work your way around the truck once it's a little warmer.

Originally Posted by bjf View Post
I am talking purely from an aesthetics standpoint.
Reply With Quote
Old February 22nd, 2013, 06:04 PM
ranewman's Avatar
Status: Offline
Rick Newman
85 Defender 110
Join Date: Dec 2011
Location: Unionville, Va
Posts: 1,439
For what its worth....when I first got my Disco, I had a ton of the same issues. Changed the headlight switch ( after 3 months of chasing Mr Lucas around) and no problems since. A contact burned out, which shorted, and acted as a ground for the brake lights. Good luck man.
06 L322 Range Rover "The Black Pearl"
97 Disco SD "Emma" (250k and going strong)
95 P38 "Gus" RIP
99 P38 Callaway Edition #106 RIP
85 Defender 110 2.5NA "Margret"
01 D2 SE7 "Cuzn It" (blown up POS)
03 D2 SE "Fred"
Hoarder of 2.5 NAD parts
"In God we trust. Everyone else keep their fucking hands where they can be seen."
Reply With Quote

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help With Electrical Gremilins mdmccallum Defender Technical Discussions 8 January 7th, 2006 01:24 AM
Electrical problem whistler110 Defender Technical Discussions 10 December 12th, 2004 12:25 PM
Electrical for beginners paulb Defender Technical Discussions 5 October 18th, 2004 12:58 PM
battery/ electrical issues steve_brooks Defender Technical Discussions 1 April 23rd, 2004 03:05 PM
on-going electrical problem... vesparover Defender Technical Discussions 3 October 23rd, 2003 10:13 AM

All times are GMT -5. The time now is 03:59 PM.