Electrical Mystery - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old October 1st, 2010, 09:05 PM
floyd650's Avatar
floyd650
Status: Offline
Alex Lapidus
1994 D90 ST #1716
Member
 
Join Date: Oct 2007
Location: Portland, OR
Posts: 138
Electrical Mystery

Here's my current electrical mystery: When I turn on the right turn signal it flashes at a regular speed but only the front blinkers are illuminated. When I hit the brakes (turn signal still on) they blink faster and the rears still don't come on. What's my issue?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old October 1st, 2010, 10:49 PM
KevinNY's Avatar
KevinNY
Status: Offline
Kevin Buckley
1973 coiler
Member
 
Join Date: Apr 2005
Location: Guilderland,NY
Posts: 1,460
I'll guess a short on the rear harness where it goes through the frame or a bad ground in the rear. When weird stuff starts to happen I always think bad ground first.
__________________
'73 SeriesIII coiler,"The Goat", Daihatsu 2.8TD,Santana,Ashcroft,ARB's,etc., now SOLD
Reply With Quote
  #3  
Old October 2nd, 2010, 02:31 AM
lynchee's Avatar
lynchee
Status: Offline
Dennis Lynch
94 D90 #699
Member
 
Join Date: Jun 2006
Location: Goffstown NH, USA
Posts: 603
I have something very similar going on, sometimes it blinks faster, sometimes slower. I also had fuel pump and fuel gauge issues. The harness is messed up somewhere inside the frame(grounding issue). I already ran new wires for the fuel pump/gauge, next is rewiring the lights.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old October 2nd, 2010, 04:22 AM
Campbell's Avatar
Campbell
Status: Offline
Rich Campbell
06 LR3 01DII D90s sold
Member
 
Join Date: Oct 2003
Location: PA
Posts: 1,512
Registry
I had the same thing happen...twice. Both times it was the harness in the frame. I had the whole thing pulled out from the frame/ bad secions replaced And have been good to go. I also left the harness out side of the frame...I just had it taped up with electrical tape and zipped tied up high.
Why at these put in the frame anyway? To protect from getting caught off road? I think they just sit in pools of water in there and get corroded
Reply With Quote
  #5  
Old October 2nd, 2010, 09:22 AM
rijosho's Avatar
rijosho
Status: Offline
Joshua
1995 Black ST - Rhinolined edition
Research Assistant/Eagle Eyes
 
Join Date: Apr 2009
Location: NYC
Posts: 16,557
Registry
Same here, intermittently. Last night had brake light stay on after disengaged, then when it went off (or maybe it was still on) the turn signal blinked much faster for about 10 minutes of use. Not annoying enough for me to care yet, as that's only the second time it's happened; both after massive rains.
__________________
Quote:
I am talking purely from an aesthetics standpoint.
Reply With Quote
  #6  
Old October 2nd, 2010, 02:40 PM
floyd650's Avatar
floyd650
Status: Offline
Alex Lapidus
1994 D90 ST #1716
Member
 
Join Date: Oct 2007
Location: Portland, OR
Posts: 138
Where in the frame is the harness?
Reply With Quote
  #7  
Old October 2nd, 2010, 10:53 PM
Campbell's Avatar
Campbell
Status: Offline
Rich Campbell
06 LR3 01DII D90s sold
Member
 
Join Date: Oct 2003
Location: PA
Posts: 1,512
Registry
It enters Up near the bulkhead passenger side and exits at the rear passenger side at the wheel well.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
electrical

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tdi electrical diagram artm Defender Technical Discussions 2 January 13th, 2006 08:52 PM
Help With Electrical Gremilins mdmccallum Defender Technical Discussions 8 January 7th, 2006 01:24 AM
Electrical problem whistler110 Defender Technical Discussions 10 December 12th, 2004 12:25 PM
Electrical for beginners paulb Defender Technical Discussions 5 October 18th, 2004 01:58 PM
on-going electrical problem... vesparover Defender Technical Discussions 3 October 23rd, 2003 11:13 AM


All times are GMT -5. The time now is 01:51 PM.


Copyright