electrical issue - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old October 26th, 2008, 07:13 PM
phunter
Status: Offline
phunter
1993 NAS 110
Member
 
Join Date: Mar 2008
Location: west virginia, usa
Posts: 59
electrical issue

lost power to radio and blower fan switch/a/c at same time while going down the road. all of a sudden no more radio or air. any suggestions
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old October 26th, 2008, 07:52 PM
Hans's Avatar
Hans
Status: Offline
Hans Haase
The D-90.com Lab Rat
Member
 
Join Date: Oct 2003
Location: Long Island, NY
Posts: 2,381
Fuse?
__________________
My oil line fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
My 100k stopped odometer fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Brace for impact, I'm in a "modifying mood". Massive thread count inbound.
Reply With Quote
  #3  
Old October 26th, 2008, 09:54 PM
phunter
Status: Offline
phunter
1993 NAS 110
Member
 
Join Date: Mar 2008
Location: west virginia, usa
Posts: 59
all fuses okay in the cabin. I could not remove the 60 amp fuse under the hood. any tricks as to check them? pulling straight out did not seem to get me anywhere. any idea which fuse could possiby explain my problems. all help is greatly appreciated.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old October 26th, 2008, 09:57 PM
Hans's Avatar
Hans
Status: Offline
Hans Haase
The D-90.com Lab Rat
Member
 
Join Date: Oct 2003
Location: Long Island, NY
Posts: 2,381
I usually use a big pair of needle nosed pliers on those fuses under the hood. They can get pretty stuck in there over time unfortunately.

I don't have my diagrams here unfortunately, won't be able to check them for a bit (my truck is a mess with its own electrical issues that I'm working on).

-Hans
__________________
My oil line fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
My 100k stopped odometer fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Brace for impact, I'm in a "modifying mood". Massive thread count inbound.
Reply With Quote
  #5  
Old October 28th, 2008, 11:13 AM
durangorover
Status: Offline
Chris Wherry
1995 D-90
Member
 
Join Date: Jul 2007
Location: Durango, CO
Posts: 69
This is along the same lines.. my interior light and cigarette lighter don't work and I've checked all fuses and they all seem to be fine??? Any thoughts.
Reply With Quote
  #6  
Old October 28th, 2008, 09:50 PM
CDeWan
Status: Offline
Clay DeWan
5.3L beastie
Member
 
Join Date: Feb 2008
Location: Raleigh, NC
Posts: 3,493
Did you take a testlight-probe while the key was on and touch each of the little silver spots on the top of the fuse to see if power is going through the fuse while it is in its holder?

If that is o.k. you might want to check if you have any corrosion on the contact face for the fuse. Running a thin cardboard nail file up and down might take some of the immediate corrosion off.

Might be off topic but on my 94 the first owner wrote in the vehicle book always to turn on the blower motor and then the AC climate control or else you end up popping the 25 amp fuse.

If your interior light and cigarette lighter are not working what about your hazard switch too?
Reply With Quote
  #7  
Old October 29th, 2008, 05:21 PM
durangorover
Status: Offline
Chris Wherry
1995 D-90
Member
 
Join Date: Jul 2007
Location: Durango, CO
Posts: 69
Hazard switch works fine. ????
Reply With Quote
  #8  
Old October 29th, 2008, 06:30 PM
GYM's Avatar
GYM
Status: Offline
Gary
97 SW
Member
 
Join Date: Jul 2006
Location: West Coast
Posts: 1,062
Quote:
Originally Posted by durangorover
This is along the same lines.. my interior light and cigarette lighter don't work and I've checked all fuses and they all seem to be fine??? Any thoughts.
Long shot...
I removed a burnt out license plate light bulb once to bring to the store as a reference and lost my dash lights, left side markers and remaining lic plate bulb in the process. Replaced the burnt out bulb and everything on that circuit came back on.
Reply With Quote
  #9  
Old November 1st, 2008, 08:52 PM
phunter
Status: Offline
phunter
1993 NAS 110
Member
 
Join Date: Mar 2008
Location: west virginia, usa
Posts: 59
still with electrical issues -- now the factory radio will start beeping about 1 hour after you park. The radio otherwise acts as if it has no power. Remember the radio and vent blower fan both died simultaneously last week.
Is the dealer helpful for these issues? As you can tell I am a new frustrated defender owner. My town does not have any independent rover shops. Any words of wisdom ? All suggestions are appreciated
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
electrical

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
110 electrical issue bcourtney Defender Technical Discussions 4 August 6th, 2008 06:40 AM
Need help diagnosing electrical issue cgalpin Defender Technical Discussions 22 January 25th, 2007 08:53 PM
95 won't start, possible fuel priming issue? jcasteel Defender Technical Discussions 1 March 15th, 2005 09:45 AM
Electrical for beginners paulb Defender Technical Discussions 5 October 18th, 2004 01:58 PM
on-going electrical problem... vesparover Defender Technical Discussions 3 October 23rd, 2003 11:13 AM


All times are GMT -5. The time now is 01:45 AM.


Copyright