Electrical gremlin - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old July 5th, 2014, 06:43 PM
azspeed
Status: Offline
Greg
85D90
Member
 
Join Date: Jan 2014
Location: Texas
Posts: 7
Electrical gremlin

So, my rear turn signals (both) are not working. First thing I did was replace the bulbs, still no go. Second thing, check the fuses, all appear to be ok, however with the poor diagram on the fuse box cover I decided to pinpoint which was the turn signal fuse. After finding it and pulling it out and putting the same fuse back in, there is now a crazy noise coming from the fuse box when I press the left turn signal. The fuse it had was a 35A fuse when the max depicted on the diagram for any fuse is 20A, so I go pick up and pick up the appropriate 15A fuse and replace it, however it's still making the noise, and no still no turn signals. Any thoughts? Relay? Ground?

Check out the video to hear the noise and let me know what you think.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old July 6th, 2014, 09:59 PM
Capt Milks's Avatar
Capt Milks
Status: Offline
Mike
Defender V-8, Defender 2.25
Member
 
Join Date: Oct 2004
Location: United States
Posts: 1,801
making a noise would lead me to think it may be the flasher. However the hazard switch also goes bad. Do you get lights with the the hazard switch? Do the front lights work? The rear lights connect on the bulkhead to the chassis loom. A good idea to give that a look. Always check the grounds too.
Reply With Quote
  #3  
Old July 7th, 2014, 01:55 PM
azspeed
Status: Offline
Greg
85D90
Member
 
Join Date: Jan 2014
Location: Texas
Posts: 7
The hazard switch works, as well as the fronts when I turn on the hazards, just not the rears. I'll try and trace the wiring and see where the rears connect. The buzzing sound still has me wondering though.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old July 7th, 2014, 02:24 PM
Overlander's Avatar
Overlander
Status: Offline
mark kellgren
in between D's in an 04 D2
Member
 
Join Date: Mar 2006
Location: Charlotte, NC
Posts: 6,531
Registry
those damn bullet connectors for the tail harness need to be inspected (on the tub under each rear quater panel window. Most of the time, the problem is with those (in my experience).
__________________
Mark Kellgren
KM4BOR

ISIL and al qaeda can go F*ck themselves...
Reply With Quote
  #5  
Old July 26th, 2014, 08:18 PM
azspeed
Status: Offline
Greg
85D90
Member
 
Join Date: Jan 2014
Location: Texas
Posts: 7
Well, I've narrowed the buzzing sound down to the clear blue Hella TB64 relay mounted behind the fusebox, part #4DM003360-00. After I pulled it out it looks like it melted on one side of the circuit board. Has anyone else had to replace this unit? There is a Lucas unit on craddock that is listed as a replacement, not sure if it's compatible though.
Reply With Quote
  #6  
Old July 26th, 2014, 08:30 PM
javelinadave
Status: Offline
-
-
Member
 
Join Date: Sep 2003
Location: -
Posts: 5,394
Rovah Farm. Ask for Trevor.
Reply With Quote
  #7  
Old July 28th, 2014, 03:00 PM
azspeed
Status: Offline
Greg
85D90
Member
 
Join Date: Jan 2014
Location: Texas
Posts: 7
Quote:
Originally Posted by javelinadave View Post
Rovah Farm. Ask for Trevor.
I've talked to Trevor before, very helpful, I'll give him a ring.

Here's a pic of the relay for anyone else that finds this thread later.

------ Follow up post added July 28th, 2014 02:02 PM ------



Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
electrical

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
i killed the last electrical gremlin! wantone Defender Technical Discussions 4 April 17th, 2013 12:14 PM
Minor electrical gremlin... wea Defender Technical Discussions 2 September 12th, 2004 08:44 PM
reciever electrical problems yellowrover Defender Technical Discussions 7 March 17th, 2004 05:13 PM
Electrical relay issues???? PMHAH Defender Technical Discussions 1 November 20th, 2003 02:32 PM
on-going electrical problem... vesparover Defender Technical Discussions 3 October 23rd, 2003 11:13 AM


All times are GMT -5. The time now is 01:47 AM.


Copyright