Defender 90 Won't Start - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old March 5th, 2016, 05:56 PM
ruggedalaskaman's Avatar
ruggedalaskaman
Status: Offline
Frank
1995 NAS D-90 #375
Member
 
Join Date: Jun 2012
Location: Anchorage, AK
Posts: 176
Registry
Defender 90 Won't Start

I have a 95 NAS 90 with the stock 3.9. ECR went through the engine before I moved back to Alaska a few months ago to include installing a new fuel pump. The vehicle has started flawlessly on the first or second crank every time until Thursday when I wanted to use it. I can hear the fuel pump pressurize when I hit the key. The vehicle cranks strong, but doesn't fire. Any thoughts?

Frank
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old March 5th, 2016, 07:48 PM
fruitpunch
Status: Offline
Marc Brouwer
66 IIa 88 Perkins powered
Member
 
Join Date: Jan 2009
Location: Stone Ridge, NY
Posts: 231
Registry
check both relays, fuel / ignition next to ECU. they are identical swap them over... if you don't hear pump you know the other one was bad.
Reply With Quote
  #3  
Old March 5th, 2016, 08:50 PM
ruggedalaskaman's Avatar
ruggedalaskaman
Status: Offline
Frank
1995 NAS D-90 #375
Member
 
Join Date: Jun 2012
Location: Anchorage, AK
Posts: 176
Registry
Thanks for the reply. Do the relays just fail like that without warning?
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old March 5th, 2016, 09:04 PM
xjahx's Avatar
xjahx
Status: Offline
JAH
'93 NAS 110, '94 NAS ST, '85 90 PU
Member
 
Join Date: Aug 2012
Location: MVY, ACK
Posts: 473
Registry
Yes.
Reply With Quote
  #5  
Old March 5th, 2016, 09:32 PM
ruggedalaskaman's Avatar
ruggedalaskaman
Status: Offline
Frank
1995 NAS D-90 #375
Member
 
Join Date: Jun 2012
Location: Anchorage, AK
Posts: 176
Registry
Thanks
Reply With Quote
  #6  
Old March 6th, 2016, 08:14 PM
ruggedalaskaman's Avatar
ruggedalaskaman
Status: Offline
Frank
1995 NAS D-90 #375
Member
 
Join Date: Jun 2012
Location: Anchorage, AK
Posts: 176
Registry
So I finally have time to check the relays today and decide to try and start it one more time. As soon as I touch the key it fires up and runs perfectly. Any thoughts of what would cause this condition?
Reply With Quote
  #7  
Old March 6th, 2016, 08:17 PM
Angus's Avatar
Angus
Status: Offline
Mike Ferguson
1994 Defender 90
Member
 
Join Date: Nov 2013
Location: Philly Area
Posts: 173
Registry
I had some issues with intermittent starting before my ignition switch packed it in, then it would not start at all. Something else to check. Good luck.
__________________
Angus
Reply With Quote
  #8  
Old March 6th, 2016, 08:17 PM
o2batsea's Avatar
o2batsea
Status: Online
Bill Adams
66 109 sw 94 lwb
Member
 
Join Date: Jul 2009
Location: kensington md
Posts: 6,502
Registry
Moisture
__________________
Bill Adams

1966 109 5 door wagon 300Tdi "spermaceti fueled"
1994 RRC LeWiB "ruining the air behind me"
1968 2A 88

All my troubles are Rover
Reply With Quote
  #9  
Old March 6th, 2016, 09:18 PM
doktorno
Status: Offline
Chris deZ.
1995 Defender SW
Member
 
Join Date: Aug 2014
Location: Houston, TX
Posts: 165
Registry
My '95 is at SWR Automotive with the same problem. Never an issue in TX, but this winter in NM a cold start issue showed up. I suspect it was over fueling at startup, causing the engine to flood. It is my understanding that this overfueling at startup intended to warm the catalytic converters was a problem that was corrected on later ECUs, but I am just internet smart on these vehicles.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
90, defender, defender 90, start

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
94 Defender won't start worsethenu Defender Technical Discussions 36 August 20th, 2014 04:51 PM
Won't crank, Won't start. revor Misc. Chit-Chat 4 September 16th, 2010 09:48 PM
94 Defender 90 cranks but won't start Charles LF Defender Technical Discussions 6 September 9th, 2009 02:43 PM
Defender won't Start DJ Menasco Defender Technical Discussions 21 January 29th, 2007 11:04 AM
Another "My Defender won't start" question MiniGuy Defender Technical Discussions 4 December 28th, 2005 12:51 PM


All times are GMT -5. The time now is 01:52 PM.


Copyright