Defender 90 (97) wont start when motor hot? - Page 2 - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #21  
Old December 29th, 2010, 01:08 PM
The Dro
Status: Offline
Dro
1988 Ninety
Member
 
Join Date: Jan 2010
Location: Annandale, VA
Posts: 6,682
Registry
Quote:
Originally Posted by Roverchef View Post
It's not that it won't crank..it won't start!
Ohh... I misunderstood.
Reply With Quote
Sponsored Links
Advertisement
 
  #22  
Old December 30th, 2010, 09:17 AM
wolfgang
Status: Offline
Nels Larson
1997 defender 90
Member
 
Join Date: Dec 2010
Location: Estes Park colorado
Posts: 7
Had the fuel pump tested and it was only putting out 19 lbs. of pressure. It should be 31 lbs. So I am having the fuel pump replaced. Parts and labor $600.00. . I hope this is the only problem. I will let you guys know when I get it back.
Reply With Quote
  #23  
Old December 31st, 2010, 06:13 PM
huck1974's Avatar
huck1974
Status: Offline
shane cates
94 d90
Member
 
Join Date: Feb 2007
Location: springfield mo
Posts: 890
Quote:
Originally Posted by wolfgang View Post
Had the fuel pump tested and it was only putting out 19 lbs. of pressure. It should be 31 lbs. So I am having the fuel pump replaced. Parts and labor $600.00. . I hope this is the only problem. I will let you guys know when I get it back.
I thought that was what your symptoms pointed too. Sorry you had to drop the cash. Its not that bad of a job. You can pull it off in an afternoon and save half your money. I'd help you do it for a six pack if you were closer. Good luck!
__________________
I love little baby ducks, old pick-up trucks, slow-moving trains, and rain
I love little country streams, sleep without dreams, sunday school in may,
And hay
And I love you too
Reply With Quote
Sponsored Links
Advertisement
 
  #24  
Old March 30th, 2011, 02:54 PM
1of40's Avatar
1of40
Status: Offline
1of40
NAS 97SW & 83 One Ten Tdi
Member
 
Join Date: Dec 2003
Location: Potomac Falls & Wintergreen, Virginia
Posts: 6,075
Registry
Did this solve your problem? I'm having a similar problem but suspect it might be the crank angle. At lease i hope it is becasue i replaced my pump a year ago 9which doesnt really mean much).
Reply With Quote
  #25  
Old March 30th, 2011, 05:16 PM
Roverchef's Avatar
Roverchef
Status: Offline
Jake K.
95 D90 SW
Member
 
Join Date: Jan 2010
Location: Deep in the Dirty South
Posts: 341
When it won't start....check and see if you have spark! If you don't, then check the wiring on the crank sensor first before you throw parts at it. It won't throw a code either if the sensor or wiring is bad.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
90, 97, defender 90, motor, start

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
'97 Defender 90 Serpentine belt crown14 For Sale - Parts 0 February 5th, 2010 04:01 PM
1997 NAS Defender 90 AC kits ECR The Vendors Loft 2 December 22nd, 2009 07:18 PM
For Sale: 1997 Land Rover Defender 90 SW WLDKGDM For Sale - Vehicles 10 January 20th, 2009 02:49 PM
Defender won't Start DJ Menasco Defender Technical Discussions 21 January 29th, 2007 11:04 AM
Defender 90 Side Jump Seats bob_o_bean Wanted 0 January 6th, 2004 02:35 AM


All times are GMT -5. The time now is 03:10 AM.


Copyright