D90 will not start possible ecu or wiring? - Page 3 - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #41  
Old December 24th, 2014, 11:30 AM
richpmnelson
Status: Offline
Rich
95' Land rover d90
Member
 
Join Date: Dec 2014
Location: Running Springs, CA
Posts: 15
Quote:
Originally Posted by leastonce View Post
Does the relay not power up for a second or so with the ignition? If that's not happening it's likely a fuse.

If you hear the sound of hooves think horses not zebras.
the fuse is good if i ground pin 16 at the ecu connection and turn on the ignition the pump kicks on. have a look at page 11 test 6 in the folowing link.
http://www.g33.co.uk/images/PDFS/14c..._injection.pdf
Reply With Quote
Sponsored Links
Advertisement
 
  #42  
Old December 24th, 2014, 12:07 PM
leastonce's Avatar
leastonce
Status: Offline
Jason England
D-90 White 95 SW #65
Site Team
 
Join Date: Jul 2009
Location: NYC
Posts: 6,078
Registry
Quote:
Originally Posted by richpmnelson View Post
hmm.. ill have to check that ive already got the dash apart, but it shouldnt effect anything it the end of the line comming from the ecu.
CEL being blown won't cause an issue.

Is fuse 18 in the main panel good?
__________________
Quote:
Soapy water / KY jelly, etc. is is basically a must. Yes, good idea to remove trim panels - only takes 5 more minutes to do so.
Car Camping Collective founding member and Chief Executive Officer
Cat Camping Collective founding member and Chief Executive Officer
Reply With Quote
  #43  
Old December 24th, 2014, 12:10 PM
richpmnelson
Status: Offline
Rich
95' Land rover d90
Member
 
Join Date: Dec 2014
Location: Running Springs, CA
Posts: 15
Quote:
Originally Posted by leastonce View Post
CEL being blown won't cause an issue.

Is fuse 18 in the main panel good?
yes please read my last post.
Reply With Quote
Sponsored Links
Advertisement
 
  #44  
Old December 24th, 2014, 01:05 PM
leastonce's Avatar
leastonce
Status: Offline
Jason England
D-90 White 95 SW #65
Site Team
 
Join Date: Jul 2009
Location: NYC
Posts: 6,078
Registry
Quote:
Originally Posted by richpmnelson View Post
yes please read my last post.
Back to pin 39. When you crank does it pulse? That is the signal for the ecu to turn the fuel pump on once the pulses are occurring at a fast enough rate and also fire the injectors.

Have you checked that the fuel rail is pressurizing ? Just thinking if it died during normal operation the fuel filter could have blocked.
__________________
Quote:
Soapy water / KY jelly, etc. is is basically a must. Yes, good idea to remove trim panels - only takes 5 more minutes to do so.
Car Camping Collective founding member and Chief Executive Officer
Cat Camping Collective founding member and Chief Executive Officer
Reply With Quote
  #45  
Old December 24th, 2014, 01:48 PM
richpmnelson
Status: Offline
Rich
95' Land rover d90
Member
 
Join Date: Dec 2014
Location: Running Springs, CA
Posts: 15
Quote:
Originally Posted by leastonce View Post
Back to pin 39. When you crank does it pulse? That is the signal for the ecu to turn the fuel pump on once the pulses are occurring at a fast enough rate and also fire the injectors.

Have you checked that the fuel rail is pressurizing ? Just thinking if it died during normal operation the fuel filter could have blocked.
the pump is not even priming, when i hot wire it i get pressure at the rails. when it died i noticed that the pump had turned off while driving. for some reason the ecu just stopped sending power to the pump relay.
Reply With Quote
  #46  
Old December 24th, 2014, 03:23 PM
leastonce's Avatar
leastonce
Status: Offline
Jason England
D-90 White 95 SW #65
Site Team
 
Join Date: Jul 2009
Location: NYC
Posts: 6,078
Registry
Do you have a rovergauge? I can send you a cable if you PM me your address. You'll need to assemble it as I don't have all the heat shrink at my apartment.

It's only solder 3 connections.

This should give you a bit more insight to what the ECU is doing with regard to the pump.

The pulsing on pin 39 is required to start the pump up for the second time after the initial prime which only lasts a second or so.
__________________
Quote:
Soapy water / KY jelly, etc. is is basically a must. Yes, good idea to remove trim panels - only takes 5 more minutes to do so.
Car Camping Collective founding member and Chief Executive Officer
Cat Camping Collective founding member and Chief Executive Officer
Reply With Quote
  #47  
Old December 24th, 2014, 08:47 PM
richpmnelson
Status: Offline
Rich
95' Land rover d90
Member
 
Join Date: Dec 2014
Location: Running Springs, CA
Posts: 15
i will probably be busy for the next couple of days, thanks for all the help you guys have given. have a merry christmas or happy holidays, witch ever you prefer.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
90, d90, ecu, start, wiring

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2 4.2 ECU's 1 3.9 ECU eliaschristeas For Sale - Parts 3 June 19th, 2013 03:15 PM
Start no start leastonce Defender Technical Discussions 10 February 25th, 2012 02:33 PM
no start... ECU? MikeRuby Defender Technical Discussions 18 August 3rd, 2010 06:36 PM
Need an ECU... looking for the ECU out of a 95 Disco or equivalent IPSC_GUY Wanted 7 February 16th, 2010 04:36 PM
95 won't start, possible fuel priming issue? jcasteel Defender Technical Discussions 1 March 15th, 2005 09:45 AM


All times are GMT -5. The time now is 10:41 AM.


Copyright