D90 will not start possible ecu or wiring? - Page 2 - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #21  
Old December 19th, 2014, 05:40 PM
richpmnelson
Status: Offline
Rich
95' Land rover d90
Member
 
Join Date: Dec 2014
Location: Running Springs, CA
Posts: 15
Quote:
Originally Posted by aka rover View Post
FYI both of the 95s in the shop are white wires black strip .



Attachment 108955
that wire is coil to ecu wire please refer to http://www.g33.co.uk/images/PDFS/14c..._injection.pdf page 1 wirring diagram. the MAFS is Blue w/ Red stripe.

------ Follow up post added December 19th, 2014 02:45 PM ------

Quote:
Originally Posted by ezzzzzzz View Post
Disconnect battery - . Pull the connector free of the ECU. Reconnect battery -. Check for 12v at pin 16 of the ECU. If it's not there your problem is between the battery+ and ignition switch. If there then turn key to run. Check for 12v at pin 19. If not there but is at pin 16 you've got a bad ignition switch or local wiring problem. If you're not getting a check engine light (even with the ECU swap) you're probably not getting 12v through the ignition switch. That also allows the fuel pump relay to kick in. You're looking well beyond the trouble area.
both 16 & 19 show 12 volts with ignition in the on postion, also i have already bypassed the ignition switch.
Reply With Quote
Sponsored Links
Advertisement
 
  #22  
Old December 20th, 2014, 05:15 AM
aka rover's Avatar
aka rover
Status: Offline
ed angel
95 D90
Member
 
Join Date: Dec 2010
Location: Anchorage Alaska
Posts: 1,132
Registry
You are correct on the wire color .

Click image for larger version

Name:	image-3786095662.jpg
Views:	156
Size:	384.8 KB
ID:	108996
__________________
95 D90 SW 4.6 ARBs 8274 37" BFGs Gigglepin twin motor 8274
94 D90 ST R380 constine green stock
85 D110 3.5 3 DR
67 NADA diesel tremec 4spd salisbury rear springs on front and a LOT MORE TO GO.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #23  
Old December 20th, 2014, 09:16 AM
richpmnelson
Status: Offline
Rich
95' Land rover d90
Member
 
Join Date: Dec 2014
Location: Running Springs, CA
Posts: 15
Quote:
Originally Posted by aka rover View Post
You are correct on the wire color .

Attachment 108996
is this pic from an online recource, or a hard copy you have?
Reply With Quote
Sponsored Links
Advertisement
 
  #24  
Old December 20th, 2014, 09:44 AM
rijosho's Avatar
rijosho
Status: Offline
Joshua
1995 Black ST - Rhinolined edition
Research Assistant/Eagle Eyes
 
Join Date: Apr 2009
Location: NYC
Posts: 16,557
Registry
Quote:
Originally Posted by richpmnelson View Post
is this pic from an online recource, or a hard copy you have?
Use some of these and save them as favorites to your smartphone or PC or MAC. 14CUX PDF and workshop manual.

http://landroverforums.com/forum/att...stems-info.pdf

http://www.internet-tools.co.uk/land...l%20(1993).pdf
__________________
Quote:
I am talking purely from an aesthetics standpoint.
Reply With Quote
  #25  
Old December 20th, 2014, 09:47 AM
Kevin88RRC's Avatar
Kevin88RRC
Status: Online
Kevin Keith
1988 RRC
Member
 
Join Date: Dec 2014
Location: Portland, Maine
Posts: 1,045
Quote:
Originally Posted by richpmnelson View Post
is this pic from an online recource, or a hard copy you have?
It's from this article…
http://www.britishv8.org/articles/rover-14cux-efi.htm
Reply With Quote
  #26  
Old December 20th, 2014, 03:02 PM
aka rover's Avatar
aka rover
Status: Offline
ed angel
95 D90
Member
 
Join Date: Dec 2010
Location: Anchorage Alaska
Posts: 1,132
Registry
Great site for conversion info.
__________________
95 D90 SW 4.6 ARBs 8274 37" BFGs Gigglepin twin motor 8274
94 D90 ST R380 constine green stock
85 D110 3.5 3 DR
67 NADA diesel tremec 4spd salisbury rear springs on front and a LOT MORE TO GO.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #27  
Old December 23rd, 2014, 01:01 PM
richpmnelson
Status: Offline
Rich
95' Land rover d90
Member
 
Join Date: Dec 2014
Location: Running Springs, CA
Posts: 15
ok i'm at the end of my rope, all signs point to the ecu but there is no way i have 2 bad ecu's, just finished cleaning and ensureing all grounds are solid, checked all fuses and conections at the coil. ecu is getting power where it needs it. but still no check engine light or power to pump relay, and yes pump and relay are in working condition. what is wrong with this thing?
Reply With Quote
  #28  
Old December 23rd, 2014, 05:30 PM
ron's Avatar
ron
Status: Offline
Ron
1994 NAS Defender 90
Member
 
Join Date: Oct 2003
Location: Harwichport MA
Posts: 5,364
if you hot wire fuel pump can you hear it run....... connect 87, 87 and 30 0n the pig tail....

the 30 is live all the time... do you have power?
If so then go down to next connection below gas fill do you have power? if so then its the pump or connection...

sorry if you already did this,,,,

pm a number and we can talk,,,,
__________________
no thanks whatever I tell you, you will low ball me
I would rather keep the parts in storage
good luck with your search
Reply With Quote
  #29  
Old December 23rd, 2014, 08:45 PM
leastonce's Avatar
leastonce
Status: Offline
Jason England
D-90 White 95 SW #65
Site Team
 
Join Date: Jul 2009
Location: NYC
Posts: 6,078
Registry
Rollover switch?
__________________
Quote:
Soapy water / KY jelly, etc. is is basically a must. Yes, good idea to remove trim panels - only takes 5 more minutes to do so.
Car Camping Collective founding member and Chief Executive Officer
Cat Camping Collective founding member and Chief Executive Officer
Reply With Quote
  #30  
Old December 23rd, 2014, 09:33 PM
tebby's Avatar
tebby
Status: Offline
Justin Tebbenkamp
95 D-90 ST
Member
 
Join Date: May 2008
Location: Blacksburg, VA, USA
Posts: 274
X2 on the rollover switch
Reply With Quote
  #31  
Old December 23rd, 2014, 10:50 PM
don's Avatar
don
Status: Offline
Don Bunnell
'86 110 3dr ST
Member
 
Join Date: Sep 2007
Location: Rumson, NJ
Posts: 4,271
Registry
I used to carry a jumper to rule out the rollover switch when my NAS wouldn't start. With the plug being on the bottom of the switch and the plastic now 20+ years old it doesn't take much to vibrate them apart. I finally zip tied the clip closed to make sure it would stay on.

Not to mention It could be tripped or even bad.
Reply With Quote
  #32  
Old December 24th, 2014, 12:11 AM
richpmnelson
Status: Offline
Rich
95' Land rover d90
Member
 
Join Date: Dec 2014
Location: Running Springs, CA
Posts: 15
Quote:
Originally Posted by leastonce View Post
Rollover switch?
are you talkimg about the inertia switch. if so, it is fine the pump gets power if i hot wire at the relay.
Reply With Quote
  #33  
Old December 24th, 2014, 08:44 AM
leastonce's Avatar
leastonce
Status: Offline
Jason England
D-90 White 95 SW #65
Site Team
 
Join Date: Jul 2009
Location: NYC
Posts: 6,078
Registry
Are the wires in the back of the alternator secure?

Do you have spark at the plugs? You mention you have it at the coil but is it reaching the plug?
__________________
Quote:
Soapy water / KY jelly, etc. is is basically a must. Yes, good idea to remove trim panels - only takes 5 more minutes to do so.
Car Camping Collective founding member and Chief Executive Officer
Cat Camping Collective founding member and Chief Executive Officer
Reply With Quote
  #34  
Old December 24th, 2014, 09:09 AM
carlosz's Avatar
carlosz
Status: Offline
Carlos
frank stein "frankie" in action RIP
Member
 
Join Date: Jun 2006
Location: east coast
Posts: 960
Registry
There is a fuse to those relays, if ok then do a wire wiggle test behind the fuse box..those connectors fail due to corrosion or poor contact.
__________________
the truck ran like a "raped ape"
A fussy warm weather creature...
Reply With Quote
  #35  
Old December 24th, 2014, 09:33 AM
Kevin88RRC's Avatar
Kevin88RRC
Status: Online
Kevin Keith
1988 RRC
Member
 
Join Date: Dec 2014
Location: Portland, Maine
Posts: 1,045
Does your '95 have an alarm or immobilizer?
Quote:
Originally Posted by Roverlab View Post
Here's where it gets interesting:
The last wire is orange/light green going to alarm unit. Reading through the RAVE, there is reference to the alarm unit having some effect on the Check Engine light as part of it's function to Immobilise the car from starting ie: the CEL wont illuminate if the Immobiliser is in effect.
From this thread but it's talking about a '97… http://www.defendersource.com/forum/...k+engine+light
Reply With Quote
  #36  
Old December 24th, 2014, 10:58 AM
richpmnelson
Status: Offline
Rich
95' Land rover d90
Member
 
Join Date: Dec 2014
Location: Running Springs, CA
Posts: 15
Quote:
Originally Posted by Kevin88RRC View Post
Does your '95 have an alarm or immobilizer?

From this thread but it's talking about a '97… http://www.defendersource.com/forum/...k+engine+light
i dont think, so ive checked for the immoblizer but they only come in later models. also im getting no check engine light what so ever.
Reply With Quote
  #37  
Old December 24th, 2014, 11:02 AM
Kevin88RRC's Avatar
Kevin88RRC
Status: Online
Kevin Keith
1988 RRC
Member
 
Join Date: Dec 2014
Location: Portland, Maine
Posts: 1,045
Silly thought… could it just be a burnt out CEL bulb causing the problem??
Reply With Quote
  #38  
Old December 24th, 2014, 11:03 AM
richpmnelson
Status: Offline
Rich
95' Land rover d90
Member
 
Join Date: Dec 2014
Location: Running Springs, CA
Posts: 15
Quote:
Originally Posted by leastonce View Post
Are the wires in the back of the alternator secure?

Do you have spark at the plugs? You mention you have it at the coil but is it reaching the plug?
i have yet to check spark at the plugs but im more worried about he fact that the ecu is not sending power to the pump relay.
Reply With Quote
  #39  
Old December 24th, 2014, 11:09 AM
leastonce's Avatar
leastonce
Status: Offline
Jason England
D-90 White 95 SW #65
Site Team
 
Join Date: Jul 2009
Location: NYC
Posts: 6,078
Registry
Does the relay not power up for a second or so with the ignition? If that's not happening it's likely a fuse.

If you hear the sound of hooves think horses not zebras.
__________________
Quote:
Soapy water / KY jelly, etc. is is basically a must. Yes, good idea to remove trim panels - only takes 5 more minutes to do so.
Car Camping Collective founding member and Chief Executive Officer
Cat Camping Collective founding member and Chief Executive Officer
Reply With Quote
  #40  
Old December 24th, 2014, 11:16 AM
richpmnelson
Status: Offline
Rich
95' Land rover d90
Member
 
Join Date: Dec 2014
Location: Running Springs, CA
Posts: 15
Quote:
Originally Posted by Kevin88RRC View Post
Silly thought… could it just be a burnt out CEL bulb causing the problem??
hmm.. ill have to check that ive already got the dash apart, but it shouldnt effect anything it the end of the line comming from the ecu.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
90, d90, ecu, start, wiring

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2 4.2 ECU's 1 3.9 ECU eliaschristeas For Sale - Parts 3 June 19th, 2013 03:15 PM
Start no start leastonce Defender Technical Discussions 10 February 25th, 2012 02:33 PM
no start... ECU? MikeRuby Defender Technical Discussions 18 August 3rd, 2010 06:36 PM
Need an ECU... looking for the ECU out of a 95 Disco or equivalent IPSC_GUY Wanted 7 February 16th, 2010 04:36 PM
95 won't start, possible fuel priming issue? jcasteel Defender Technical Discussions 1 March 15th, 2005 09:45 AM

» Defender Registry

mannarosa

motard

248

xjahx
Add your Defender

All times are GMT -5. The time now is 10:51 AM.


Copyright