crazy electrical problem.... - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old August 26th, 2009, 08:08 AM
Campbell's Avatar
Campbell
Status: Offline
Rich Campbell
06 LR3 01DII D90s sold
Member
 
Join Date: Oct 2003
Location: PA
Posts: 1,512
Registry
crazy electrical problem....

I thought I would start a new thread about this problem. My 90 has been running hot with the a/c on. Thanks to the great advice on this site I determined it was in fact an electrical problem. When I had the lights and everything else I could think of on the temp gauge would shoot up. As soon as I turned the lights off it would come down a bit. Well this morning I fried my second light switch in a month.

I don't know jack about electrics so I'm hoping some of the experts here can explain it to me like I'm a third grader!!

Thanks as always.
Rich
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old August 26th, 2009, 03:34 PM
Campbell's Avatar
Campbell
Status: Offline
Rich Campbell
06 LR3 01DII D90s sold
Member
 
Join Date: Oct 2003
Location: PA
Posts: 1,512
Registry
bump?
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
electrical

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
97 electrical problem Campbell Defender Technical Discussions 13 January 7th, 2010 04:29 AM
Electrical starting problem JKC Defender Technical Discussions 14 September 8th, 2009 09:20 AM
Bonehead Electrical Problem floyd650 Defender Technical Discussions 6 April 28th, 2009 02:22 PM
Electrical problem whistler110 Defender Technical Discussions 10 December 12th, 2004 12:25 PM
on-going electrical problem... vesparover Defender Technical Discussions 3 October 23rd, 2003 11:13 AM


All times are GMT -5. The time now is 12:59 PM.


Copyright