Cold Starts - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old November 3rd, 2007, 06:45 AM
JBfoot's Avatar
JBfoot
Status: Offline
Joe Barefoot
'94 D90, '07 D110, '08 LR2, '09 D90
Member
 
Join Date: Aug 2007
Location: Cayman Islands
Posts: 85
Cold Starts

Hi Rover Gurus...
Let me describe my '94 NAS Defender's symptoms.
Runs fine, starts fine....but since the cold weather, after a cold start, the idle plunges to zero and the engine shuts off. I have to restart and either depress the accelerator a little for a while, or get right on the road and keep going. After it warms up, there seems to be no problem. This seems to have coincided with the cooler weather coming, but that may be coincidence. Whuda ya think?
Thanks,
Joe Barefoot
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
start

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cold air output from heater RyanB16 Defender Technical Discussions 19 December 26th, 2008 09:47 AM
surprised at 300Tdi cold weather starts Gkase Misc. Chit-Chat 6 December 6th, 2006 09:11 AM
Cold Weather Starter Problems boshea Defender Technical Discussions 9 October 25th, 2005 04:35 PM
a/c not cold jblieb Defender Technical Discussions 1 September 15th, 2005 10:34 PM
? for you cold weather people javelinadave Defender Technical Discussions 8 November 24th, 2004 12:34 PM


All times are GMT -5. The time now is 09:45 PM.


Copyright