clutch issue - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old July 14th, 2012, 06:30 PM
K9Phil
Status: Offline
Phil
1994 D-90 #1184
Member
 
Join Date: Jun 2012
Location: PNW
Posts: 98
clutch issue

Picked up my new (to me) D90 from the shop yesterday after having several upgrades and mods done, none of which had anything to do with the clutch, and the clutch seemed to be sticking a little. This morning, when I backed out of the garage and took my foot off the clutch, it stuck completely, fully depressed. I had to push it hard a couple of times to get it to release. I also noticed some fluid on the floor mat directly under the pedal. Not much, maybe 3 or 4 drops worth, that seems to have dripped from the clutch pedal. Drove it around for a couple of hrs and as soon as it warmed up, it seemed ok. Thoughts?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old July 14th, 2012, 07:03 PM
Manimal's Avatar
Manimal
Status: Offline
Carl Jonsson
1995 NAS D90 #219
Site Team
 
Join Date: Sep 2008
Location: Portland, OR
Posts: 3,236
Your slave or master cylinder needs to be replaced. Just a matter of time before I gives out.
__________________
Land Rovers. A loosely associated collection of parts, generally traveling in the same direction.
Reply With Quote
  #3  
Old July 14th, 2012, 07:21 PM
nathanwind's Avatar
nathanwind
Status: Offline
Jason Lavender
88-90-127-LR3
D-90 Source Vendor
 
Join Date: Jan 2008
Location: Saratoga NY
Posts: 8,743
Registry
Irony is I've had to do the 90 last month, 88 is down as we speak with it out (same part # ironically), and I think the 110 needs it too. If you search for this you'll find all these horror stories of how "hard" it is. It's a piece of cake of you know how to bleed brakes or the clutch.

------ Follow up post added July 14th, 2012 07:24 PM ------

Here's a writeup I did:
http://www.defendersource.com/forum/...06&postcount=7
__________________
Jason Lavender
'71 Series IIA
'88 127 #F96 DKN
'94 90 NAS #324
'06 LR3 HSE

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

(10% discount for DSource members, use coupon code "D90")

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old July 14th, 2012, 08:31 PM
K9Phil
Status: Offline
Phil
1994 D-90 #1184
Member
 
Join Date: Jun 2012
Location: PNW
Posts: 98
One of the things they did last week was install SS brake lines. Any chance of that having anything to do with this?
Reply With Quote
  #5  
Old July 14th, 2012, 08:41 PM
nathanwind's Avatar
nathanwind
Status: Offline
Jason Lavender
88-90-127-LR3
D-90 Source Vendor
 
Join Date: Jan 2008
Location: Saratoga NY
Posts: 8,743
Registry
Quote:
Originally Posted by K9Phil View Post
One of the things they did last week was install SS brake lines. Any chance of that having anything to do with this?
Doubt it unless they loosened the clutch reservoir for some reason, but I doubt they'd do that on a LHD truck - access is not a problem.
__________________
Jason Lavender
'71 Series IIA
'88 127 #F96 DKN
'94 90 NAS #324
'06 LR3 HSE

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

(10% discount for DSource members, use coupon code "D90")

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
clutch

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
200tdi / LT77 clutch issue kjva Defender Technical Discussions 11 May 29th, 2012 10:41 PM
weird clutch issue tomaco1 Defender Technical Discussions 4 August 6th, 2011 07:34 AM
Do I have a clutch issue ? Or is this something really bad paulb Defender Technical Discussions 3 October 18th, 2010 09:05 PM
Clutch issue? Help with diagnosis..... Hans Defender Technical Discussions 13 December 18th, 2005 05:19 PM
Clutch spring MOD--MUST HAVE evilfij Defender Technical Discussions 2 July 3rd, 2005 10:03 PM


All times are GMT -5. The time now is 11:47 PM.


Copyright